1015 Reversible Primes (20分)

问题

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.
Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.
Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.
Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

解决方法

分析:数学问题

#include<iostream>
#include<math.h>
#include<vector>
using namespace std;
bool prime(int n)
{
	if (n <= 1) return false;
	int sqr = int(sqrt(n*1.0));
	for (int i = 2; i <= sqr; i++)
	{
		if (n%i == 0) return false;
	}
	return true;
}
int main()
{
	int n, d;
	vector<int>v;
	while (scanf("%d", &n) != EOF)
	{
		if (n < 0) break;
		scanf("%d", &d);
		if (!prime(n))
		{
			printf("No\n");
			continue;
		}
		else
		{
			v.clear();
			while (n != 0)
			{
				v.push_back(n%d);
				n = n / d;
			}
			for (int i = 0; i < v.size(); i++)
			{
				n = n * d + v[i];
			}
			if (prime(n)) printf("Yes\n");
			else printf("No\n");
		}
	}
	return 0;
}

后记

题目难度不大只是进制转换和素数的函数有些忘记了。。。。果然是很久不碰代码了o(╥﹏╥)o

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值