1102 Invert a Binary Tree (25分)

问题

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can’t invert a binary tree on a whiteboard so fuck off.

Now it’s your turn to prove that YOU CAN invert a binary tree!
Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.
Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.
Sample Input:

8
1 -

0 -
2 7

5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

解决方法

分析:树的遍历

#include<iostream>
#include<algorithm>
#include<vector>
#include<string>
using namespace std;
struct node
{
	int parent=-1, left, right;
};
string in;
vector<node>v;
vector<int>level;
void pre(int root)
{
	if (v[root].left != -1) pre(v[root].left);
	in += to_string(root) + " ";
	if (v[root].right != -1) pre(v[root].right);
}
int main()
{
	int n, root, flag = 0;
	string s1, s2;
	scanf("%d", &n);
	cin.ignore();
	v.resize(n);
	for (int i = 0; i < n; i++)
	{
		cin >> s1 >> s2;
		if (s1 == "-") v[i].left = -1;
		else
		{
			v[i].left = stoi(s1);
			v[stoi(s1)].parent = i;
		}
		if (s2 == "-") v[i].right = -1;
		else
		{
			v[i].right = stoi(s2);
			v[stoi(s2)].parent = i;
		}
	}
	for (int i = 0; i < v.size(); i++)
	{
		if (v[i].parent == -1) root = i;
	}
	level.push_back(root);
	printf("%d", root);
	pre(root);
	while (level.size())
	{
		root = level[0];
		level.erase(level.begin());
		if (flag) printf(" %d", root);
		flag = 1;
		if (v[root].right != -1) level.push_back(v[root].right);
		if (v[root].left != -1) level.push_back(v[root].left);
	}
	cout << endl;
	reverse(in.begin(), in.end());
	in.erase(in.begin());
	cout << in;
	return 0;
}

后记

♦这道题琢磨了很久,难点在于,我利用vector建好树以后,不知道如何层序遍历,后来参考了其他的代码才有所启发。
♦中序遍历采用递归,没有什么难度

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值