HDU 1312 Red and Black (搜索)

31 篇文章 0 订阅

链接http://acm.hdu.edu.cn/showproblem.php?pid=1312

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

题意是 .是可以走的,问你最多能走多少个点,基础的bfs

题解从起点开始,把所有能走的位置都走一遍,即可算出能走多少个点

#include<iostream>
#include<queue>
#include<string.h>
using namespace std;
int dir[4][2] = { 0, 1, 0, -1, 1, 0, -1, 0 };
int vis[30][30], sum = 0;
char map[30][30];
int n, m;
struct node{
	int x, y;
};
void bfs(int x, int y){
	queue<node>q;
	q.push({ x, y });
	while (!q.empty()){
		x = q.front().x, y = q.front().y;
		q.pop();
		if (vis[x][y])continue;         //如果该点走过了即跳过 
		if (map[x][y] == '.')sum++;      //如果该点能走sum++ 
		vis[x][y] = 1;                 //对走过的点标记 
		for (int i = 0; i < 4; i++)
		{
			int xx = x + dir[i][0];
			int yy = y + dir[i][1];
			if (!vis[xx][yy] && map[xx][yy] != '#'&&xx < n&&xx >= 0 && yy < m&&yy >= 0)//判断要走的点是否合法 
				q.push({ xx, yy });
		}
	}
}
int main(){
	while (cin >> m >> n && (m || n)){
		memset(vis, 0, sizeof(vis));
		sum = 0;
		for (int i = 0; i < n; i++)
			cin >> map[i];
		for (int i = 0; i < n; i++)
			for (int j = 0; j < m; j++)
				if (map[i][j] == '@')  //找到起点坐标 
					bfs(i, j);
		cout << sum + 1 << endl;  //最开始的位置也算一点,输出时加一 
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值