hdu1789简单贪心Doing Homework again

**Doing Homework again
Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework… Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.**

Output
For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input
3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output
0
3
5

这个题目大佬说几分钟就做出了了,本蒻蒟花了3个多小时,还参考了一下别人的代码,唉丢人。说一下这题把,我一开始是用分数/天数降序的,发现这样并不能达到最优值,因为天数我没有考虑到位,在生活中,我们当然是希望尽可能在最后一天做那门课程的作业,这样在交作业之前可以把前面的作业先做了,那么做作业的原则啊,先做高数最高的,如果分数相同就做时间最短的,按照这个思路就可以把代码写出来了。
个人代码(c++)//参考了别人的数组用来记录最后一天我要做的课程

#include<iostream>
#include<string>
#include<string.h>
#include<algorithm>
using namespace std;
struct time{
	double a;//最后的期限 
	double b;//扣的分数 
};
bool cmp(struct time a,struct time b){
	if(a.b==b.b)
	return a.a<a.b;
	return a.b>b.b; 
}
struct time a[1005];
int limit[1005];
int main()
{
	int t;
	while(cin>>t){
		for(int p=0;p<t;p++){
			memset(a,0,sizeof(a));
			memset(limit,0,sizeof(limit));
			int q;//科目 
			cin>>q;
			for(int i=0;i<q;i++){
				cin>>a[i].a;
			}
			for(int i=0;i<q;i++){
				cin>>a[i].b;
			}
			int sum=0,t=0;
			sort(a,a+q,cmp);
		//	for(int i=0;i<q;i++){
		//		cout<<a[i].a<<"  "<<a[i].b<<endl;
		//	}
			for(int i=0;i<q;i++){
				t=a[i].a;
					while(t){
						if(!limit[t]){//表示第t天还没有做过作业 
							limit[t]=1;//表示第t天我要做这门作业,这天已经被占用了 
							 break;
						}else{
							t--;
						}
						if(t==0){
							sum+=a[i].b;
						}
					}
			}
			cout<<sum<<endl;
		}
	}
} 
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值