PATA 1046 Shortest Distance (20分)

PATA 1046 Shortest Distance (20分)

题目描述:The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.


输入格式:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10^​5
​​ ]), followed by N integer distances D​1 D​2​ ⋯ D​N​ , whereDi​ is the distance between the i-th and the (i+1)-st exits, and DN​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10^​4​​ ), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10^​7)
​​ .

输出格式:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

输入样例:

5 1 2 4 14 9
3
1 3
2 5
4 1

输出样例:

3
10
7

题意:有N个节点组成一个圆圈,然后输入每个节点之间的距离,然后求M个节点到节点之间的最短距离。
思路:若直接记录每个节点之间的距离,则每次查询都要遍历每个节点,时间复杂度较大,所以借鉴柳神的代码,记录第一个节点到每个节点的距离为总长度,在区dis[right-1]-dis[left-1]与sum-(dis[right-1]-dis[left-1])中的小者。

代码:

#include <iostream>
#include <vector>
using namespace std;
int main(){
	int n;
	scanf("%d",&n);
	vector<int> dis(n+1);
	int temp;//输入距离
	int sum=0,left,right,cnt;
	for(int i=1;i<=n;i++){
		scanf("%d",&temp);
		sum += temp;
		dis[i] = sum;
	//	printf("sum=%d,dis[%d]=%d\n",sum,i,dis[i]);
	} 
	scanf("%d",&cnt);
	for(int i=1;i<=cnt;i++){
		scanf("%d %d",&left,&right);
		if(left>right){
			swap(left,right);
		}
		int way;
		way = dis[right-1]-dis[left-1];
		printf("%d\n",min(way,sum-way));
	}	
	return 0;
}
}

GOGOGOGO!
Love Joyee forever!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值