C - Heavy Transportation

Description

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo’s place) to crossing n (the customer’s place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

题意为求最大的载货量,每种走法的最大载货量等于该走法中所有路径的最小载货量。

注意:

1、初始化时,使用0来初始化ma数组。

2、每次选取距离最远的结点来更新dis数组。

3、每次松弛操作保存最大的最小载货量。

4、每组输出后面要有两个换行。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int INF = 0x3f3f3f3f, N = 1005;

int ma[N][N];
int dis[N];
bool vis[N];
int n, m, st, ed;

void init()
{
	// 初始化ma数组
	for (int i = 1; i <= n; i++)
		for (int j = 1; j <= n; j++)
			ma[i][j] = 0;
}

void Dijk()
{
	for (int i = 0; i < n - 1; i++){
		int maxv = 0, k; // k用来存储最大的且没被松弛过的城市
		for (int j = 1; j <= n; j++){
			if (maxv < dis[j] && !vis[j]){
				maxv = dis[j];
				k = j;
			}
		}
		vis[k] = 1;
		for (int h = 1; h <= n; h++)
			dis[h] = max(dis[h], min(dis[k], ma[k][h]));
	}	
}

int main(void)
{
	int t;
	int a, b, c;
	cin >> t;
	for (int idx = 1; idx <= t; idx++) {
		cin >> n >> m;
		// 初始化ma数组 
		init();
		for (int i = 0; i < m; i++){
			cin >> a >> b >> c;
			if (ma[a][b] < c)
				ma[a][b] = ma[b][a] = c;
		}
		// 输入起点和终点 
		st = 1, ed = n;
		// 初始化dis数组
		for (int i = 1; i <= n; i++)
			dis[i] = ma[st][i];
		// 初始化vis数组
		memset(vis, 0, sizeof vis);
		vis[st] = 1;
		
		Dijk();
		printf("Scenario #%d:\n", idx);
		printf("%d\n\n", dis[ed]);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值