PAT(A)1028 List Sorting (25分)

在这里插入图片描述

Sample Input

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output

000001 Zoe 60
000007 James 85
000010 Amy 90

思路:
三种不同的输入代表三种不同的排序,如果相同则根据id排序。
代码

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <string>
#include <cstring>
#include <cmath>

using namespace std;

#define endl '\n'

typedef long long ll;

struct node {
    string id;
    string name;
    int score;
}peo[100005];

bool cmp1(node a, node b)
{
    return a.id < b.id;
}

bool cmp2(node a, node b)
{
    if (a.name != b.name)
        return a.name < b.name;
    return a.id < b.id;
}

bool cmp3(node a, node b)
{
    if (a.score != b.score)
        return a.score < b.score;
    return a.id < b.id;
}

int main()
{
    int n, m;

    cin >> n >> m;

    for (int i = 0; i < n; ++i)
    {
        cin >> peo[i].id;
        cin >> peo[i].name;
        cin >> peo[i].score;
    }

    if (m == 1)
        sort(peo, peo + n, cmp1);
    if (m == 2)
        sort(peo, peo + n, cmp2);
    if (m == 3)
        sort(peo, peo + n, cmp3);

    for (int i = 0; i < n; ++i)
        cout << peo[i].id << " " << peo[i].name << " " << peo[i].score << endl;

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值