PAT_A1006 | Sign In and Sign Out

1006 Sign In and Sign Out (25分)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

 

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

 

Sample Output:

SC3021234 CS301133

一、存储结构

每个个体有id、登录时间(in)、登出时间(out)三个变量,所以我们通过结构体储存

并且声明三个结构体变量:

temp:处理输入的个体,暂时储存

unlocked:储存当下登入时间最早的个体

locked:储存当下登出时间最晚的个体

 

二、具体算法

比较时间先后:直接利用 "cstring" 库中的 strcmp 函数进行比较即可。

 

对于输入的数据,暂时存储在结构体变量temp中。

然后通过比较对应的时间,更新unlocked和locked变量。

 

三、注意

1、locked和unlucked的初值要想清楚

2、清楚字符串比较函数 strcmp(str1, str2)的返回值

  •     当str1 > str2,返回一个正数(注意不一定是1)
  •     当str1 = str2,返回整数0
  •     当str1 < str2,返回一个负数(注意不一定是-1)

 

具体代码如下: 

//
// Created by LittleCat on 2020/1/31.
//

#include <cstdio>
#include <cstring>

struct person {
    char id[16];
    char in[16];
    char out[16];
} temp, unlocked, locked;

int main() {

    strcpy(unlocked.in, "24:00:00");
    strcpy(locked.out, "00:00:00");

    int t;
    for(scanf("%d", &t); t; t--) {
        scanf("%s %s %s", temp.id, temp.in, temp.out);
        if(strcmp(temp.in, unlocked.in) < 0)
            unlocked = temp;
        if(strcmp(temp.out, locked.out) > 0)
            locked = temp;
    }

    printf("%s %s\n", unlocked.id, locked.id);
}

 



end 

欢迎关注个人公众号“鸡翅编程”,这里是认真且乖巧的码农一枚,旨在用心写好每一篇文章,平常会把笔记汇总成推送更新~
 

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值