PAT_A1036 | Boys vs Girls

1036 Boys vs Girls (25分)

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade​F​​−grade​M​​. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

 

Sample Output 1:

Mary EE990830
Joe Math990112
6

 

Sample Input 2:

1
Jean M AA980920 60

 

Sample Output 2:

Absent
Jean AA980920
NA

 一、存储结构

每个个体有姓名(name)、性比(gender)、学号(id)、成绩(grade)4个变量,所以我们通过结构体储存

并且声明三个结构体变量:

temp:处理输入的个体,暂时储存

female_highest:储存当下成绩最高的女同学

male_lowest:储存当下成绩最低的男同学

 

二、注意

1、female_highestmale_lowest的初值要想清楚

 

具体代码如下:

//
// Created by LittleCat on 2020/1/31.
//

#include <cstdio>

struct student {
    char name[11];
    char gender;
    char id[11];
    int grade;
} temp, female_highest, male_lowest;

int main() {

    female_highest.grade = -1;
    male_lowest.grade = 101;

    int t;
    for (scanf("%d", &t); t; t--) {
        scanf("%s %c %s %d",temp.name, &temp.gender, temp.id, &temp.grade);

        if(temp.gender == 'M') {
            if(temp.grade < male_lowest.grade)
                male_lowest = temp;
        } else {
            if(temp.grade > female_highest.grade)
                female_highest = temp;
        }
    }

    bool flag = true;
    if(female_highest.grade != -1)
        printf("%s %s\n", female_highest.name, female_highest.id);
    else {
        printf("Absent\n");
        flag = false;
    }

    if(male_lowest.grade != 101)
        printf("%s %s\n", male_lowest.name, male_lowest.id);
    else {
        printf("Absent\n");
        flag = false;
    }

    if(flag)
        printf("%d\n", female_highest.grade- male_lowest.grade);
    else
        printf("NA\n");

    return 0;
}


end 

欢迎关注个人公众号“鸡翅编程”,这里是认真且乖巧的码农一枚,旨在用心写好每一篇文章,平常会把笔记汇总成推送更新~
 

在这里插入图片描述

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值