PAT_A1027 | Colors in Mars

1027 Colors in Mars (20point(s))

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

 

Sample Output:

#123456

 简单来说,就是将输入的三个数字分别转化为对应的十三进制数输出。

而且限定了转化结果肯定是两位数(不足两位数的用0补全),所以简单的转化即可。

AC代码如下:

//
// Created by LittleCat on 2020/2/3.
//
#include <cstdio>

char number[3] = {'A', 'B', 'C'};

void print(int num) {
    int t = num / 13;
    if (t >= 10)
        printf("%c", number[t - 10]);
    else
        printf("%d", t);

    int p = num % 13;
    if (p >= 10)
        printf("%c", number[p - 10]);
    else
        printf("%d", p);
}

int main() {
    int r, g, b;

    scanf("%d %d %d", &r, &g, &b);

    printf("#");
    print(r);
    print(g);
    print(b);
}


 

end 

欢迎关注个人公众号 鸡翅编程 ”,这里是认真且乖巧的码农一枚。

---- 做最乖巧的博客er,做最扎实的程序员 ----

旨在用心写好每一篇文章,平常会把笔记汇总成推送更新~

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值