PAT_A1005 | Spell It Right

1005 Spell It Right (20point(s))

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10​100​​).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

 

Sample Output:

one five

由于最多100位数,就算每一位都是9,最大也就900。所以说加和的最终结果最多三位。

那么直接分类输出即可:三位、两位、一位(0也算一位)。

 

具体代码如下:

//
// Created by LittleCat on 2020/2/10.
//

#include <cstdio>


#define N 105

int main() {
    char number[10][6] = {"zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};
    char input[N];
    scanf("%s", input);

    int ans = 0;
    for (int i = 0; input[i] != '\0'; i++)
        ans += input[i] - '0';

    if (ans >= 100)
        printf("%s %s %s\n", number[ans / 100],number[ans % 100 /10], number[ans %10]);
    else if(ans >= 10)
        printf("%s %s\n", number[ans / 10], number[ans % 10]);
    else
        printf("%s\n", number[ans]);

    return 0;
}


end 

欢迎关注个人公众号 鸡翅编程 ”,这里是认真且乖巧的码农一枚。

---- 做最乖巧的博客er,做最扎实的程序员 ----

旨在用心写好每一篇文章,平常会把笔记汇总成推送更新~

在这里插入图片描述

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值