POJ3984(迷宫问题)

迷宫问题

Description

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output

左上角到右下角的最短路径,格式如样例所示。
Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

思路

裸题一道,目的是为了学习一下路径打印,常见的打印有回溯打印或者直接记录打印。

#include <iostream>
#include <string.h>
#include <string>
#include <vector>
#include <queue>
#include <stdio.h>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 100010
using namespace std;
int mp[10][10],vis[10][10];
int dx[]={0,0,1,-1};
int dy[]={1,-1,0,0};
struct Node{
	int x,y;
	int stepx[30],stepy[30],cnt;
}a;
queue<Node>q;
void BFS()
{
	while(!q.empty()){
		Node p = q.front(),ptr;
		q.pop();
		if(p.x==4&&p.y==4){
			printf("(0, 0)\n");				//起点 
            for(int i=0;i<p.cnt;i++)
                printf("(%d, %d)\n",p.stepx[i],p.stepy[i]);
            return ;
		}
		ptr = p;						//少了这句话就会错,因为这句话执行了赋值操作。
		for(int i=0;i<4;++i){
            ptr.x=p.x+dx[i];
            ptr.y=p.y+dy[i];
            if(ptr.x>=0&&ptr.x<=4&&ptr.y>=0&&ptr.y<=4&&vis[ptr.x][ptr.y]==0&&mp[ptr.x][ptr.y]==0){
                vis[ptr.x][ptr.y]=1;
                ptr.stepx[ptr.cnt]=ptr.x;
                ptr.stepy[ptr.cnt++]=ptr.y;
                q.push(ptr);
            }
        } 
	}
}
int main()
{
	for(int i = 0;i<5;++i){
		for(int j = 0;j<5;++j){
			cin>>mp[i][j]; 
			vis[i][j] = 0;
		}
	}
	while(!q.empty()){
		q.pop();
	}
	Node start;
	start.x = 0;start.y = 0;start.cnt = 0;
	q.push(start);
	BFS();
	return 0;
}

愿你走出半生,归来仍是少年~

  • 1
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值