POJ(3984):迷宫问题

ime Limit: 1000MS Memory Limit: 65536K
Total Submissions: 33752 Accepted: 19211

Description

定义一个二维数组: 

int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};


它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>

using namespace std;

struct pos{
    int r,c;
    int father;
    pos (int rr=0,int cc=0,int ff=0):r(rr),c(cc),father(ff){}//必须设初值,因为下面定义结构体数组类型。
};
pos dir[4] = {pos(-1,0),pos(1,0),pos(0,-1),pos(0,1)};
pos que[30];
int maze[8][8];
int main()
{
    memset(maze,0xff,sizeof(maze));//只能赋值为0,1赋值为其他数要用for
    for(int i = 1;i <= 5;i++)
        for(int j = 1;j <= 5;j++)
            scanf("%d",&maze[i][j]);
    int head = 0;
    int tail = 0;
    que[tail] = pos(1,1,-1);
    tail++;
    while(head != tail){
        pos ps = que[head];
        if(ps.r == 5 && ps.c == 5){
            vector <pos> vt;
            while(true){
                vt.push_back(pos(ps.r,ps.c,0));
                if(ps.father == -1)
                    break;
                    ps = que[ps.father];
            }
                for( int i = vt.size()-1; i >= 0; -- i )
                    cout << "(" << vt[i].r-1 << ", " <<
                    vt[i].c-1 << ")" << endl;
                    return 0;
        }
        else{
            for(int i =0;i < 4;i++){
                int r = ps.r,c = ps.c;
                if(!maze[r+dir[i].r][c+dir[i].c]){
                    que[tail++] = pos(r+dir[i].r,c+dir[i].c,head);
                    maze[r+dir[i].r][c+dir[i].c] = 1;
                }
            }
        }
        head++;
    }

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值