You are to find all the two-word compound words in a dictionary. A two-word compound word is a
word in the dictionary that is the concatenation of exactly two other words in the dictionary.
Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will
be no more than 120,000 words.
Output
Your output should contain all the compound words, one per line, in alphabetical order.
Sample Input
a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra
Sample Output
alien
newborn
思路:就是找一个单词能不能由另外两个单词组成,例如alien就由a和lien组成。将每个单词存入map里,然后将每个单词断开,断电从第一个字母开始到最后一个,如果前半截在map里存在,再看后半截存在于map里吗。都存在就输出
#include<iostream>
#include<algorithm>
#include<string>
#include<map>
#include<string.h>
using namespace std;
string str[120500];
int main() {
string a,b;
map<string, bool>m;
m.clear();
int n=0,i,j,p,o;
while (cin>>str[n]) {
m[str[n]] = true;
n++;
}
for (i = 0; i < n; i++) {
for (j = 1; j < str[i].length(); j++) {
a = str[i].substr(0, j );
if (m[a]) {
b = str[i].substr(j );
if (m[b]) {
cout << str[i] << endl;
break;
}
}
}
}
return 0;
}