算法题 STL-06-复合词

You are to find all the two-word compound words in a dictionary. A two-word compound word is a
word in the dictionary that is the concatenation of exactly two other words in the dictionary.
Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will
be no more than 120,000 words.
Output
Your output should contain all the compound words, one per line, in alphabetical order.
Sample Input
a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra
Sample Output
alien
newborn

思路:就是找一个单词能不能由另外两个单词组成,例如alien就由a和lien组成。将每个单词存入map里,然后将每个单词断开,断电从第一个字母开始到最后一个,如果前半截在map里存在,再看后半截存在于map里吗。都存在就输出

#include<iostream>
#include<algorithm>
#include<string>
#include<map>
#include<string.h>
using namespace std;
string str[120500];
int main() {
	string a,b;
	map<string, bool>m;
	m.clear();
	int n=0,i,j,p,o;
	while (cin>>str[n]) {
		m[str[n]] = true;
		n++;
	}
	for (i = 0; i < n; i++) {
		for (j = 1; j <  str[i].length(); j++) {
			a = str[i].substr(0, j );
			if (m[a]) {
				b = str[i].substr(j );
				if (m[b]) {
					cout << str[i] << endl;
					break;
				}
			}
			
		}
	}
	return 0;
}
  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值