算法题 深/广搜-06-Square

Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
Output
For each case, output a line containing “yes” if is is possible to form a square; otherwise output “no”.
Sample Input
3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5
Sample Output
yes
no
yes

思路:看看给的木棒能不能构成正方形,因为所有木棒都要用所以用深搜。剪枝:最长的木棒大于边长就不行,平均值带小数点的也不行,因为木棒不能分割
然后就深搜即可

#include<stdio.h>
#include<algorithm>
int l,sum;
int a[205];
int visit[205] = {0};
int n;
using namespace std;
int  dfs(int x,int number,int len) {
	int q;
	if (x == 4) {//算够四条边了退出循环,其实算完第三条边就已经可以构成正方形了
		return 1;
	}
	for (q = number; q >=0; q--) {//从最大边开始算
		if (visit[q] == 0) {
			visit[q] = 1;
			if (len+a[q]<l) {
				if (dfs(x, q-1, len+a[q]) == 1) {
					return 1;
				}
			}
			else if (len + a[q] == l) {
				 if(dfs(x + 1, n - 1, 0))
					 return 1;
			}
			visit[q] = 0;
		}
	}
	return 0;
}
int main() {
	int num;
	scanf("%d",&num);
	while (num--) {
		scanf("%d", &n); 
		sum = 0;
		memset(visit, 0, sizeof(visit));
		for (int i = 0; i < n; i++) {
			scanf("%d", &a[i]);
			sum = sum + a[i];
		}
		sort(a, a + n);
		l = sum / 4;
		if (l * 4 != sum || n < 4 || l < a[n - 1]) {//剪枝(I带小数点的肯定不符合要求,最大边大于平均的也不符合)
			printf("no\n");
			continue;
		}
		if (dfs(0, n - 1, 0))
			printf("yes\n");
		else
			printf("no\n");
	}
	return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值