A Bug's Life(并查集,更新)

A Bug’s Life

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing “Scenario #i:”, where i is the number of the scenario starting at 1, followed by one line saying either “No suspicious bugs found!” if the experiment is consistent with his assumption about the bugs’ sexual behavior, or “Suspicious bugs found!” if Professor Hopper’s assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

题意

若雨妹妹在Debug。他惊奇的发现 Bug有两种性别,异性之间才交往,他感觉很奇怪,于是要做个实验。在他的实验中,Bug们已经被从1开始编好号了。此外,Bug的性别很好辨别。
因为若雨妹妹太懒了,他懒得去分析他总结出来的bug数据。你需要根据数据判断是否存在同性恋,输入有 t 组数据,每组数据给出bug数量n, 和关系数m, 以下m行给出相交往的一对Bug编号 a, b。只需要判断有没有,按题目要求输出。
输入的第一行包含方案的数量。每个场景以一行给出,给出了由单个空格分隔的bug数(至少一个,最多2000个)和交互数(最多1000000)。在以下行中,每个交互以两个不同的bug号的形式给出,由单个空格分隔。bug从1开始连续编号。

代码
#include <cstdio>
#include <iostream>

using namespace std;

int f[2020], r[2020], n, m;

void init() {
    for (int i = 1; i <= n; i++) {
        f[i] = i;
        r[i] = 1;
    }
}

int find(int x) {
    if (f[x] == x) {
        return x;
    } else {
        // 根据根结点更新性别
        int temp = f[x];
        f[x] = find(temp);
        r[x] = (r[x] + r[temp] + 1) % 2;
    }
    return f[x];
}

void merge(int x, int y) {
    int fx = find(x), fy = find(y);
    if (fx != fy) {
        f[fx] = fy;
    }
    // 改变根结点的性别
    r[fx] = (r[y] - r[x]) % 2;
}

int main() {
    int t, a, b, flag, c = 1;
    cin >> t;
    while (t--) {
        flag = 0;
        cin >> n >> m;
        init();
        for (int i = 1; i <= m; i++) {
            cin >> a >> b;
            if (flag) {
                continue;
            }
            if (find(a) == find(b)) {
                if (r[a] == r[b]) {
                    flag = 1;
                }
            } else {
                merge(a, b);
            }
        }
        if (flag) {
            printf("Scenario #%d:\nSuspicious bugs found!\n\n", c++);
        } else {
            printf("Scenario #%d:\nNo suspicious bugs found!\n\n", c++);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值