03-树2 List Leaves

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves’ indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

4 1 5

解题思路

按从上到下,从左到右的顺序,找到树的所有叶子节点,即采用层次遍历的方式寻找叶子节点
创建树,用check数组找到树的根节点并返回,利用队列实现树的层次遍历,判断每个节点是否是叶子节点,是则输出

#include<iostream>
#include<queue>
#include<vector> 
using namespace std;
#define Tree int
#define Null -1
const int maxn = 10;
struct TreeNode{
	Tree Left;
	Tree Right;
}T[maxn];
queue<int> q;
Tree MakeTree();
int main()
{
	Tree Root = MakeTree(); //创建树
	q.push(Root);
	Tree temp;
	bool flag = true;
	while(!q.empty()){
		temp = q.front();
		q.pop();
		if(T[temp].Left == Null && T[temp].Right == Null){ //输出叶节点 
			if(flag)
				flag = false;
			else
				printf(" ");
			printf("%d",temp);
		}
		if(T[temp].Left != Null) q.push(T[temp].Left); //左子树入队
		if(T[temp].Right != Null) q.push(T[temp].Right); //右子树入队 
	}
	printf("\n");
	return 0;
}
Tree MakeTree()
{
	int n,i;
	char cl,cr;
	cin>>n;
	vector<int> check(n,0);
	for(i = 0; i < n; i++){
		cin>>cl>>cr;
		if(cl != '-'){
			T[i].Left = cl - '0';
			check[T[i].Left] = 1;
		}
		else T[i].Left = Null;
		if(cr != '-'){
			T[i].Right = cr - '0';
			check[T[i].Right] = 1;
		}
		else T[i].Right = Null;
	}
	for(i = 0; i < n; i++)
		if(!check[i]) break;
	return i;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值