POJ 2387 Til the Cows Come Home

Til the Cows Come Home

题目链接:点击跳转

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 102423 Accepted: 33091

Description
Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1…N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

Line 1: Two integers: T and N

Lines 2…T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1…100.

Output

Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.

解题思路:
尝试使用了邻近表和堆优化的实现,优势就是占的内存空间会比较小

代码如下:

#include<iostream>
#include <queue>
#include <cstring>
namespace {
    using std::priority_queue;
    using std::cin;
    using std::cout;
    using std::endl;
    using std::ios;
}
typedef long long ll;
const int N = 2005;
const int inf =0x3f3f3f3f;
struct Edge{
    int from,to,next,val;
}e[N<<2];
int ans,head[N],n,m,dist[N],vis[N];
inline void init(){
    ans=0;
    memset(head,-1,sizeof(head));
}
inline void add(int from,int to,int val){
    e[ans]=Edge{from,to,head[from],val};
    head[from]=ans++;
}
struct node{
    int index,dist;
    bool operator < (const node &a)const{
        return dist>a.dist;
    }
};
inline void Dijkstra(){
    for(int i=1;i<=n;i++){
        vis[i]=0;
        dist[i]=inf;
    }
    dist[n]=0;
    priority_queue<node>q;
    q.push(node{n,0});
    while(!q.empty()){
        node now=q.top();
        q.pop();
        if(vis[now.index])continue;
        vis[now.index]=1;
        for(int i=head[now.index];i!=-1;i=e[i].next){
            if(dist[e[i].to]>dist[now.index]+e[i].val){
                dist[e[i].to]=dist[now.index]+e[i].val;
                q.push(node{e[i].to,dist[e[i].to]});
            }
        }
    }
}
int main(){
    ios::sync_with_stdio(false);
    while(cin>>m>>n){
        init();
        for(int i=0;i<m;i++){
            int from,to,val;
            cin>> from>>to>>val;
            add(from,to,val);
            add(to,from,val);
        }
        Dijkstra();
        cout<<dist[1]<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值