E - Alignment (最长上升子序列)

35 篇文章 0 订阅
22 篇文章 0 订阅

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity.

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line.

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n).

There are some restrictions:
• 2 <= n <= 1000
• the height are floating numbers from the interval [0.5, 2.5]

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

题意:我们要找一个最小值x,使得移走x个人,使得队列中的每个人都至少能看到最左边和最右边的一侧。

题解:我们对于每一个数a[i],求出包含在内的最长上升子序列,和最长下降子序列(即倒过来的最长上升子序列)。

然后枚举找出最优值即可

#include<iostream>
#include<cstring>
using namespace std;
int l[1010],r[1010];
double a[1010];
int sum,ans;
int main()
{
    int n;
    cin>>n;
    for(int i=1;i<=n;i++)
        cin>>a[i];
    for(int i=1;i<=n;i++)//求从前往后包含a[i]的最长递增序列长度
    {
        l[i]=1;
        for(int j=1;j<i;j++)
        {
            if(a[j]<a[i])
                l[i]=max(l[i],l[j]+1);
        }
    }
    for(int i=n;i>=1;i--)//求从后往前包含a[i]的最长递增序列长度
    {
        r[i]=1;
        for(int j=n;j>i;j--)
        {
            if(a[j]<a[i])
                r[i]=max(r[i],r[j]+1);
        }
    }
    for(int i=1;i<=n;i++)
    {
        for(int j=i+1;j<=n;j++)
            ans=max(ans,l[i]+r[j]);
    }
    cout<<n-ans<<endl;  
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值