poj1836——正逆两次dp求最大值

题目链接:http://poj.org/problem?id=1836

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity.

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line.

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n).

There are some restrictions:
• 2 <= n <= 1000
• the height are floating numbers from the interval [0.5, 2.5]

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

题目翻译

在军队中,一个排由n名士兵组成。在上午的检查中,士兵们在船长面前排成一条直线。船长对他的士兵的对齐方式不满意;确实,士兵按其代码号排列:1,2,3 ,.船长要求一些士兵离开防线,因为留在防线的士兵没有改变他们的位置,但越来越近,形成一条新线,每个士兵可以通过长视线看到至少一条线的四肢(左或钻机)如果士兵没有比他身高高或等于他的身高和四肢的士兵,士兵会看到四肢。‎
‎写一个程序,知道每个士兵的高度,确定必须出线的士兵的最低‎
‎人数。‎

‎输入‎

‎在输入的第一行上写上士兵人数n。在第二行上写入一系列最多为 5 位精度的 n 浮动数字,并用空格字符分隔。此行中的 k-th 数字表示具有代码 k (1 <= k <= n) 的士兵的高度。有一些限制: ‎
‎= 2 <= n <= 1000 ‎
‎= 高度是间隔 [0.5, 2.5] 的浮动数字‎

 

‎输出‎

‎唯一的产出线将包含必须离开这条线的士兵人数。

 

先解释下题意,就是求最少挪走多少士兵后队列中的任意一个士兵都可看到左边或者右边的最后一个人

就是一个三角形,左边递增,右边递减,求能待在队列中的最大人数(都是不严格单调)

其实就是让求LIS,就是先从前往后求一次LIS,再从后往前求一次LIS,然后从开始枚举区间,求出最大的人数,再用总人数一减就是最少挪走多少士兵。

#include <iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
int main(int argc, char** argv) {
	int n;
	while(~scanf("%d",&n)){
		double a[1005],b[1005];
		int dp1[1005],dp2[1005];
		for(int i = 1;i<=n;++i){
			scanf("%lf",&a[i]);
			dp1[i]=1;
			dp2[i]=1;
//			b[n-i+1]=a[i];
		}
//		for(int i = 1;i<=n;++i) printf("%lf ",b[i]);
		for(int i = 1;i<=n;++i)
			for(int j = 1;j<=i-1;++j)
				if(a[j]<a[i])
					dp1[i]=max(dp1[i],dp1[j]+1);
		for(int i = n;i>=1;--i)
			for(int j = n;j>i;--j)
				if(a[j]<a[i])
					dp2[i]=max(dp2[i],dp2[j]+1);
		int maxn=0;
		for(int i = 1;i<=n;i++){
			for(int j = i+1;j<=n;++j){
				if(maxn<dp1[i]+dp2[j])
					maxn=dp1[i]+dp2[j];
			}
		}
	    printf("%d\n",n-maxn);
	}
	return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值