E - Find The Multiple POJ - 1426(DFS枚举二进制数)

E - Find The Multiple

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

题意:找到n的倍数并且只含有0和1。
思路:因此题数据问题,就暂不考虑越界问题,保证答案在 unsigned long long 范围内。利用二进制遍历的二叉树的性质来做,用dfs来遍历整颗二叉树。(详见点我

正宗做法应该要用到同余模定理来解决越界问题的。在这里只了解那颗遍历二叉树就好啦。

代码:

#include <iostream>
#include <cstdio>

using namespace std;

typedef unsigned long long ll;

ll ans;
int isp;   // 找到答案后,防止不必要的递归。

void dfs( ll n, int k )    // k是位数,防止超过ll的范围。
{
    if ( k>19||isp==1 ) {
        return ;
    }
    if ( n%ans==0 ) {
        cout << n << endl;
        isp = 1;
        return ;
    }

    dfs(n*10,k+1);
    dfs(n*10+1,k+1);
}

int main()
{
    while ( cin>>ans && ans!=0 ) {
        isp = 0;
        dfs(1,1);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值