C - Heavy Transportation POJ - 1797(最长路)

C - Heavy Transportation POJ - 1797

Background

Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem

You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo’s place) to crossing n (the customer’s place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

题意:小虎开了一家公司卖钢筋,送到客户家里的每一段路都有最大限重,现在找出一条路,能送尽可能多的钢筋。

抽象出来就是:N个点,M条边,每条边有权值。求一条1号点到N号点的路径,要求使得路径中的边权最小值最大。

思路:直接改一下dijstra的代码,变换成求最长路的代码。这里数据中不能出现环。

代码:

#include <iostream>
#include <cstring>
#define inf 0x3f3f3f

using namespace std;

int a[1002][1002];
int via[1002];
int dis[1002];
int n,m,i,j;

void dijstra(int v0)
{
    for ( i=1; i<=n; i++ ) {
        dis[i] = a[v0][i];
    }
    
    while ( 1 ) {
        int maxx = 0;  // 与最短路相反
        int u;
        for ( i=1; i<=n; i++ ) {
            if ( via[i]==0 && dis[i]>maxx ) {  // 与最短路相反,找最大点
                maxx = dis[i];
                u = i;
            }
        }
        if ( maxx==0 ) {
            break ;
        }
        via[u] = 1;
        for ( i=1; i<=n; i++ ) {
            if ( via[i]==0 && a[u][i]<inf && dis[i]<min(dis[u],a[u][i]) ) {
                dis[i] = min(dis[u],a[u][i]) ; // 与最短路相反,小得更新成大的
            }
        }
    }
    cout << dis[n] << endl << endl;
}

int main()
{
    int listt;
    cin >> listt;
    for ( int ji=1; ji<=listt; ji++ ) {
        cin >> n >> m;
        memset(via,0,sizeof(via));
        memset(a,0,sizeof(a));  // 与最短路相反,初始化为0
        
        for ( i=0; i<m; i++ ) {
            int x,y,z;
            cin >> x >> y >> z;
            if ( a[x][y]<z ) {  // 与最短路相反
                a[x][y] = a[y][x] = z;
            }
        }
        cout << "Scenario #" << ji << ":" << endl;
        dijstra(1);
    }

    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值