J - Invitation Cards POJ - 1511(邻接表+两次堆优化的dijkstra)

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery.

The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where ‘X’ denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan.

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees.

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.

Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.

Sample Input

2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50

Sample Output

46
210

题意:前面描述冗长可以先跳过,直接看input和output部分,看个大体意思再看一下描述的最后一段,基本就理解题意了。有若干城市和单向公交路线,现在很多acm志愿者在1处,每个志愿者去一个城市,求志愿者到每个城市再回来的总时间。

思路:首先城市数量最多1000000个,所有不能用邻接矩阵只能用邻接表了。先求出1到所有其他点的总时间,存起来。再将所有单向路逆置,再求1到所有其他点的总时间存起来。两部分相加就是答案。

注:答案用long long 存。 输入用scanf。

代码:

#include <iostream>
#include <cstring>
#include <queue>
#include <stdio.h>
#define inf 0x3f3f3f

using namespace std;

typedef struct no {
    int v, date;
} ty;

bool operator < ( const ty &a, const ty &b )
{
    return a.date>b.date;
}

struct node {
    int v,w,next;
} a[1000005];

int head[1000005];
int dis[1000005];
int via[1000005];
int v[1000005],u[1000005],w[1000005]; // 方便之后邻接表的逆置
int cnt;
int n,m;
ty t,d;

void add(int x, int y, int z)  // 邻接表的存储
{
    a[cnt].v = y;
    a[cnt].w = z;
    a[cnt].next = head[x];
    head[x] = cnt;
    cnt ++;
}

long long dijkstra( int v0 ) // 堆优化的dijkstra
{
    memset(dis,inf,sizeof(dis)); // 初始距离为inf
    dis[v0] = 0;
    priority_queue <ty> Q;
    t.v = v0;
    t.date = 0;
    Q.push(t);

    while ( !Q.empty() ) {
        if ( via[Q.top().v]==1 ) {
            Q.pop();
            continue ;
        }
        t = Q.top();
        Q.pop();
        int u = t.v;
        dis[u] = t.date;
        via[u] = 1;

        for ( int i=head[u]; i!=-1; i=a[i].next ) {
            if ( via[a[i].v]==0 && dis[a[i].v]>dis[u]+a[i].w ) {
                dis[a[i].v] = dis[u]+a[i].w;
                d.v = a[i].v;
                d.date = dis[d.v];
                Q.push(d);
            }
        }
    }

    long long ans = 0;
    for ( int i=1; i<=n; i++ ) { // 存一下答案
        ans += dis[i];
    }
    return ans;
}

int main()
{
    int listt,i;
    long long ans; // 用int会越界
    scanf("%d",&listt);
    while ( listt-- ) {
        memset(head,-1,sizeof(head)); // 初始化为-1
        cnt = 0;
        ans = 0;
        memset(via,0,sizeof(via));
        scanf("%d %d",&n,&m);
        for ( i=0; i<m; i++ ) {
            scanf("%d %d %d",&u[i],&v[i],&w[i]); // 用cin会超时
            add(u[i],v[i],w[i]);
        }
        ans += dijkstra(1);

        memset(head,-1,sizeof(head));
        cnt = 0;
        memset(via,0,sizeof(via));
        for ( i=0; i<m; i++ ) {
            add(v[i],u[i],w[i]);
        }
        ans += dijkstra(1);

        cout << ans << endl;
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值