A Simple Problem with Integers ( 线段树 lazy 模板 )

A Simple Problem with Integers ( 线段树 lazy 模板 )

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

 

思路:线段树区间改值,lazy思想。

 

模板代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#define mid ((left+right)>>1)
#define lson node*2,left,mid
#define rson node*2+1,mid+1,right
typedef long long ll;

using namespace std;

const int maxn = 2e5 + 1000;
ll a[maxn];
ll tree[maxn*4];
ll lazy[maxn*4];
int n,m;

void up( int node )
{
    tree[node] = tree[node*2] + tree[node*2+1];
}

void built_tree( int node, int left, int right )
{
    if ( left==right ) {
        tree[node] = a[left];
        return ;
    }
    built_tree(lson);
    built_tree(rson);
    up(node);
}

void down( int node, int len )
{
    if ( lazy[node] ) {
        lazy[node*2] += lazy[node];
        lazy[node*2+1] += lazy[node];
        tree[node*2] += lazy[node]*(len-(len/2));
        tree[node*2+1] += lazy[node]*(len/2);
        lazy[node] = 0;
    }
}

void update( int node, int left, int right, int L, int R, int date )
{
    if ( left>=L && right<=R ) {
        tree[node] += date*(right-left+1);
        lazy[node] +=  date;
        return ;
    }
    down(node,right-left+1);
    if ( L<=mid ) {
        update(lson,L,R,date);
    }
    if ( R>mid ) {
        update(rson,L,R,date);
    }
    up(node);
}

ll query( int node, int left, int right, int L, int R )
{
    if ( L<=left && right<=R ) {
        return tree[node];
    }
    down(node,right-left+1);
    ll ans = 0;
    if ( L<=mid ) {
        ans += query(lson,L,R);
    }
    if ( R>mid ) {
        ans += query(rson,L,R);
    }
    return ans;
}

int main()
{
    memset(tree,0,sizeof(tree));
    memset(lazy,0,sizeof(lazy));
    scanf("%d %d",&n,&m);
    int i,j;
    char str[5];
    int L,X,R;
    for ( i=1; i<=n; i++ ) {
        scanf("%lld",&a[i]);
    }
    built_tree(1,1,n);
    while ( m-- ) {
        scanf("%s",str);
        if ( str[0]=='C' ) {
            scanf("%d %d %d",&L,&R,&X);
            update(1,1,n,L,R,X);
        }
        else if ( str[0]=='Q' ) {
            scanf("%d %d",&L,&R);
            printf("%lld\n",query(1,1,n,L,R));
        }
    }

    return 0;
}

 

还有一个比较好模板:https://blog.csdn.net/qq_41286356/article/details/85946725

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值