Maximum GCD UVA - 11827(输入坑)

Given the N integers, you have to find the maximum GCD (greatest common divisor) of every possible pair of these integers.

Input

The first line of input is an integer N (1 < N < 100) that determines the number of test cases. The following N lines are the N test cases. Each test case contains M (1 < M < 100) positive integers that you have to find the maximum of GCD.

Output

For each test case show the maximum GCD of every possible pair.

Sample Input

3

10 20 30 40

7 5 12

125 15 25

Sample Output

20

1

25

题意:对于给定的一组数,求该组数中两两gcd的最大值。
思路:这道题的话,简单gcd,关键点在于输入。

AC代码:

#include <stdio.h>
#include <string>
#include <string.h>
#include <algorithm>
#include <iostream>
#include <math.h>
typedef long long ll;
const int maxx=100010;
const int inf=0x3f3f3f3f;
using namespace std;
int gcd(int a,int b)
{
    return b?gcd(b,a%b):a;
}
int a[maxx];
int main()
{
    int n;
    char c;
    while(~scanf("%d",&n))
    {
        while(n--)
        {
            memset(a,0,sizeof(a));
            int nn=0,m=0;
            while(1)
            {
                scanf("%d",&a[nn++]);
                while((c=getchar())==' ');//读空格
                ungetc(c,stdin);//将一个字符返回到输入流中,即将数字放在数组a中
                if(c=='\n')//换行退出
                    break;
            }
            nn--;
            for(int i=0; i<=nn; i++)
            {
                for(int j=i+1; j<=nn; j++)
                {
                    m=max(m,gcd(a[i],a[j]));
                }
            }
            printf("%d\n",m);
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值