Maximum GCD UVA - 11827 (gcd ,输入)

Given the N integers, you have to find the maximum GCD (greatest common divisor) of every possible
pair of these integers.
Input
The first line of input is an integer N (1 < N < 100) that determines the number of test cases.
The following N lines are the N test cases. Each test case contains M (1 < M < 100) positive
integers that you have to find the maximum of GCD.
Output
For each test case show the maximum GCD of every possible pair.
Sample Input
3
10 20 30 40
7 5 12
125 15 25
Sample Output
20
1
25

暴力的gcd ,输入很少见,一直卡在这。。。

// 这个题真是醉了,居然卡在输入上

#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<queue>
#include<algorithm>

#define ll long long

using namespace std;

int gcd(int a,int b)
{
    if( a < b)
    {
        int tmp = a;
        a = b;
        b = tmp;
    }
    return b==0? a : gcd(b,a%b);    
}
int a[150];
int num[150];

int main()
{
    int n;
    scanf("%d",&n);
    getchar();     // 吸收回车 
    for(int i=0;i<n;i++)
    {
        int flag = 1;
        int cnt = 0;
        char ch;

        while( ( ch = getchar() ) != '\n')
        {
            if( '0' <= ch && ch <= '9')
                {
                    ungetc(ch,stdin);     // 如果是数字,将它退流 
                    scanf("%d",&a[cnt++]);
                }
        }

        int maxn;
        maxn = -1;
        int tmp;

        for(int j = 0; j < cnt; j ++)
            for(int k = 0; k < j; k ++)
                {
                    tmp = gcd( a[j], a[k] );
                    if( tmp > maxn)
                        maxn = tmp;
                }

        printf("%d\n",maxn);
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值