Happy 2006 (POJ-2773)(容斥原理+二分)

Two positive integers are said to be relatively prime to each other if the Great Common Divisor (GCD) is 1. For instance, 1, 3, 5, 7, 9...are all relatively prime to 2006.

Now your job is easy: for the given integer m, find the K-th element which is relatively prime to m when these elements are sorted in ascending order.

Input

The input contains multiple test cases. For each test case, it contains two integers m (1 <= m <= 1000000), K (1 <= K <= 100000000).

Output

Output the K-th element in a single line.

Sample Input

2006 1
2006 2
2006 3

Sample Output

1
3
5

题意:给你m和k,让你求出从1开始的第k个与m互质的数。

思路:这道题的话,乍一看,可以想到用容斥原理来求,因为容斥原理可以求出1~n中所有与m互质的个数,但是我们不好判断第几个与m互质的数是多少。所以我们用到了二分查找,来不断更新数值。

AC代码:

#include <stdio.h>
#include <string>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <queue>
#include <stack>
#include <map>
#include <set>
typedef long long ll;
const int maxx=100010;
const int mod=10007;
const int inf=0x3f3f3f3f;
using namespace std;
ll p[maxx];
ll q[maxx];
ll m,K,k;
void getp(ll n)
{
    k=0;
    for(ll i=2; i*i<=n; i++)
    {
        if(n%i==0)
        {
            p[k++]=i;
            while(n%i==0)
                n/=i;
        }
    }
    if(n>1)
        p[k++]=n;
}
ll nop(ll n)
{
    ll sum=0,t=0;
    q[t++]=-1;
    for(ll i=0; i<k; i++)
    {
        ll x=t;
        for(ll j=0; j<x; j++)
        {
            q[t]=q[j]*p[i]*(-1);
            t++;
        }
    }
    for(ll i=1; i<t; i++)
        sum+=n/q[i];
    return sum;
}
int main()
{
    while(~scanf("%lld%lld",&m,&K))
    {
        getp(m);
        ll l=1,r=1e18;
        ll mid,ans;
        while(l<=r)
        {
            mid=(l+r)>>1;
            if((mid-nop(mid))>=K)
            {
                r=mid-1;
            }
            else
                l=mid+1;
        }
        printf("%lld\n",l);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值