A - How many integers can you find HDU - 1796(容斥原理)

  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.

Input

  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.

Output

  For each case, output the number.

Sample Input

12 2
2 3

Sample Output

7

给你一个数N,和一个具有M个数的集合,让你从[1,N−1][1,N−1]里边找到能够被集合里边任意一个数整除的数的个数, 
eg:N=12,M={2,3}N=12,M={2,3} 
所以ans=7ans=7

数字构成的集合就是
{2,3,4,6,8,9,10}
代码:


//Full of love and hope for life

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <queue>
#include <vector>
#include <bits/stdc++.h>
#define inf 0x3f3f3f3f
//https://paste.ubuntu.com/
//https://www.cnblogs.com/zzrturist/    //博客园
//https://blog.csdn.net/qq_44134712     //csdn

using namespace std;
const int N=5e3+10;
typedef long long ll;
const int mod=1e9+7;

ll a[1010];

int main(){
    ll n,m,x;
    while(scanf("%lld%lld",&n,&m)!=EOF){
        int k=0;
        for(ll i=1;i<=m;i++){
            scanf("%lld",&x);
            if(x>=1&&x<=20){
                a[++k]=x;
            }
        }
        ll m=1<<k;
        ll sum=0;
        for(ll i=1;i<m;i++){
            int cnt=0;
            ll lcm=1;
            for(int j=0;j<k;j++){
                if(1&(i>>j)){
                    lcm=(lcm*a[j+1])/(__gcd(lcm,a[j+1]));
                    cnt++;
                }
            }
            if(cnt&1){
                sum+=(n-1)/lcm;
            }
            else{
                sum-=(n-1)/lcm;
            }
        }
        cout << sum << endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZ --瑞 hopeACMer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值