FatMouse's Speed (最长上升子序列+记录路径)

FatMouse’s Speed (最长上升子序列+记录路径)

问题描述:
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
(胖老鼠认为老鼠越胖,它跑得越快。为了证明这一点,你需要从一组老鼠身上收集数据,然后将这些数据的尽可能大的子集放入一个序列中,这样权重就会增加,而速度就会降低。)
输入描述:
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.
The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.
Two mice may have the same weight, the same speed, or even the same weight and speed.
(输入包含一组鼠标的数据,每行一个鼠标,文件结束时结束。
特定鼠标的数据将由一对整数组成:第一个以克表示大小,第二个以厘米每秒表示速度。两个整数都在1到10000之间。每个测试用例中的数据将包含最多1000只小鼠的信息。
两只老鼠可能有相同的体重,相同的速度,甚至相同的重量和速度。)
输出描述
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],…, m[n] then it must be the case that
W[m[1]] < W[m[2]] < … < W[m[n]]
and
S[m[1]] > S[m[2]] > … > S[m[n]]
In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.
(你的程序应该输出一系列的数据;第一行应该包含一个数字n;剩下的n行应该每个都包含一个正整数(每个代表一个鼠标)。如果这n个整数是m[1] m[2],…,那么情况一定是这样的
W[m[1]] < W[m[2]] <…< W [m [n]]

S[m[1]] > S[m[2]] >…> S [m [n]]
为了使答案正确,n应该尽可能大。
所有的不等式都是严格的:权重必须严格增加,速度必须严格减少。对于给定的输入,可能有许多正确的输出,您的程序只需要找到一个。)
样例输入:
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900
样例输出:
4
4
5
9
7
AC代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <iostream>
using namespace std;
int dp[10010],ans[10010];
struct node
{
    int x,y,id,f;
} mouse[10010];
bool cmp(node x,node y)
{
    if(x.x!=y.x)return x.x<y.x;
    return x.y>y.y;
}
int main()
{
    int index=1,i,j;
    while(~scanf("%d%d",&mouse[index].x,&mouse[index].y))
    {
        mouse[index].id=index;
        mouse[index].f=0;
        index++;
    }
    if(index==1)
    {
        printf("0\n");
        return 0;
    }
    sort(mouse+1,mouse+index,cmp);
    dp[1]=1;
    for(i=1; i<index; i++)
    {
        dp[i]=1;
        for(j=1; j<i; j++)
        {
            if(mouse[j].y>mouse[i].y&&mouse[j].x<mouse[i].x)
            {
                if(dp[j]+1>dp[i])
                {
                    dp[i]=dp[j]+1;
                    mouse[i].f=j;
                }
            }
        }
    }
    j=1;
    for(i=2; i<index; i++)
        if(dp[i]>dp[j])j=i;
    printf("%d\n",dp[j]);
    index=0;
    while(mouse[j].f)
    {
        ans[index++]=mouse[j].id;
        j=mouse[j].f;
    }
    printf("%d\n",mouse[j].id);
    for(i=index-1; i>=0; i--)
        printf("%d\n",ans[i]);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值