Til the Cows Come Home (poj 2387)(单源最短路)

Til the Cows Come Home (poj 2387)

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.

题目翻译:

贝西在外面的田里,她想回到谷仓,在农夫约翰早上叫醒她挤奶之前尽可能多地睡一会儿。贝西需要美容觉,所以她想尽快回去。

农夫约翰的田里有N个(2 <= N <= 1000)个地标,唯一的编号是1..地标1是谷仓;贝茜整天站着的那片苹果园是地标性的N.奶牛在田野里用T (1 <= T <= 2000)在地标之间画出各种长度的双向牛道。贝西对自己的导航能力不太自信,所以一旦开始,她总是沿着一条路线走到底。

根据地标之间的步道,确定贝西返回谷仓必须走的最小距离。可以保证存在这样的路由。

输入

*第一行:两个整数:T和N

*线2 . .T+1:每一行都用三个空格分隔的整数描述一个轨迹。前两个整数是路线经过的地标。第三个整数是路径的长度,范围1..100。

输出

*第一行:一个整数,贝茜从地标N到地标1的最小距离。

样例输入

5 5

1 2 20

2 3 30

3 4 20

4 5 20

1 5 100

样例输出

90

提示

输入详细信息:

有五个地标。

输出详细信息:

贝西可以沿着4、3、2和1条小路回家

思路:这道题是很经典的单源最短路模板题。

AC代码:

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <math.h>
#define MAX 0x3f3f3f3f
using namespace std;
int dp[2010][2010];
int dis[1010];
int vis[1010];
int main()
{
    int t,n;
    int k,i,j;
    int a,b,x;
    while(~scanf("%d %d",&t, &n))
    {
        memset(vis,0,sizeof(vis));
        memset(dis,0,sizeof(dis));
        for(i=1; i<=n; i++)
        {
            dp[i][i]=0;
            for(j=1; j<i; j++)
                dp[i][j]=dp[j][i]=MAX;
        }
        for(i=1; i<=t; i++)
        {
            scanf("%d %d %d",&a, &b, &x);
            if(dp[a][b]>x)
                dp[a][b]=dp[b][a]=x;
        }
        for(i=1; i<=n; i++)
            dis[i]=dp[1][i];
        int min;
        vis[1]=1;
        for(i=0; i<n; i++)
        {
            min=MAX;
            k=1;
            for(j=1; j<=n; j++)
            {
                if(vis[j]==0 && min>dis[j])
                {
                    min=dis[j];
                    k=j;
                }
            }
            vis[k]=1;
            for(j=1; j<=n; j++)
            {
                if(vis[j]==0 && dis[j]>dis[k]+dp[k][j])
                    dis[j]=dis[k]+dp[k][j];
            }
        }
        printf("%d\n",dis[n]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值