A Simple Problem with Integers (POJ-3468)

A Simple Problem with Integers (POJ-3468)

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

题目翻译:

有N个整数,A1 A2…,一个。您需要处理两种操作。一种操作类型是在给定的区间内为每个数字添加给定的数字。另一种是要求给定区间内的数的和。

输入

第一行包含两个数字N和Q. 1≤N,Q≤100000。

第二行包含N个数字,A1 A2…,一个。-1000000000≤Ai≤1000000000

接下来的每一行Q代表一个操作。

“C a b C”的意思是把C加到Aa, Aa+1,…, Ab. -10000≤c≤10000。

“Q a b”表示查询Aa, Aa+1,…,Ab。

输出

您需要按顺序回答所有Q命令。一行一个答案。

提示

总和可能超过32位整数的范围。

思路:

线段树模板题,因为忘考虑范围而wa两发。。。。

AC代码:

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <math.h>
#include <algorithm>
#include <stdlib.h>
#include <queue>
#include <stack>
#include <map>
#include <vector>
#define PI 3.1415926
#define inf 0x3f3f3f3f
const int maxn=1e5+10;
using namespace std;
long long Sum[maxn<<2];
long long A[maxn<<2];
void PushUp(int rt)
{
    Sum[rt]=Sum[rt<<1]+Sum[rt<<1|1];
}
void PushDown(int rt, int m)
{
    if(A[rt]) //若有标记,则将标记向下移动一层
    {
        A[rt<<1]+=A[rt];
        A[rt<<1|1]+=A[rt];
        Sum[rt<<1]+=(m-(m>>1))*A[rt];
        Sum[rt<<1|1]+=(m>>1)*A[rt];
        A[rt]=0;//取消本层标记
    }
}
void Build(int l,int r,int rt)
{
    A[rt]=0;
    if(l==r)
    {
        scanf("%lld",&Sum[rt]);
        return;
    }
    int m=(l+r)>>1;
    Build(l,m,rt<<1);
    Build(m+1,r,rt<<1|1);
    PushUp(rt);
}
void Update(int x, int y, long long k, int l, int r, int rt)
{
    if(x<=l && y>=r)
    {
        Sum[rt]+=(r-l+1)*k;
        A[rt]+=k;
        return;
    }
    int m=(l+r)>>1;
    PushDown(rt,r-l+1);//向下更新
    if(x<=m)
        Update(x,y,k,l,m,rt<<1);
    if(y>m)
        Update(x,y,k,m+1,r,rt<<1|1);
    PushUp(rt);//向上更新
}
long long Query(int x,int y,int l,int r,int rt)
{
    if(l>=x && r<=y)
        return Sum[rt];
    PushDown(rt,r-l+1);
    int m=(l+r)>>1;
    long long num=0;
    if(m>=x)
        num+=Query(x,y,l,m,rt<<1);
    if(m<y)
        num+=Query(x,y,m+1,r,rt<<1|1);
    return num;
}
int main()
{
    int n,m;
    char s[10];
    int x,y;
    long long z;
    scanf("%d%d",&n,&m);
        Build(1,n,1);
        while(m--)
        {
            scanf("%s",s);
            if(s[0]=='Q')
            {
                scanf("%d%d",&x,&y);
                printf("%lld\n",Query(x,y,1,n,1));
            }
            if(s[0]=='C')
            {
                scanf("%d%d%lld",&x,&y,&z);
                Update(x,y,z,1,n,1);
            }
        }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值