PAT练习题 P1018 Public Bike Management (30分) 【单源最短路】


传送门:P1018


1018 Public Bike Management (30分)

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S3, we have 2 different shortest paths:

PBMC -> S1 -> S​3. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S1​​ and then take 5 bikes to S​3 , so that both stations will be in perfect conditions.
PBMC -> S​2​​ -> S​3​​ . This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:
Each input file contains one test case. For each case, the first line contains 4 numbers: C​max(≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; S​p , the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers C​i (i=1,⋯,N) where each C​i​​ is the current number of bikes at S​i​​ respectively. Then M lines follow, each contains 3 numbers: S​i​​ , S​j​​ , and T​ij​​ which describe the time T​ij​​ taken to move betwen stations S​i​​ and S​j​​ . All the numbers in a line are separated by a space.

Output Specification:
For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format:
0−>S​1−>⋯−>S​p​​ . Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S​p​​ is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge’s data guarantee that such a path is unique.

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0



题目大意:
城市公共自行车站,每个站台最大能容纳 Cmax 的自行车,我们称 Cmax/2 为每个站台的完美状态,现在有一辆大货车从补给站台出发,要到达 sp 站台,为了使途中的每个站台到达完美状态,使用如果一个站台多自行车,它会收回,少则补充。大货车始终会走最短路径(时间最短)。问你大货车最少要补充或收回多少自行车,并打印相应路径


解题思路:
由最短路我们想到最短路算法-迪杰斯特拉(单源最短路),我们只要在原来的算法上稍加修改,记录下最短路径,再在最短路径上进行搜索计算,找到最小补给车辆的路径(如果补给相同,找收回最小)。



AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<vector>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
const int N=1e3+10;
int c,n,sp,m;
int C[N];
int mp[N][N],vis[N],dis[N];
vector<int> pre[N];
vector<int> path,g;
void dijkstra(int st,int n)//最短路算法
{
  for(int i=1;i<=n;i++)
    dis[i]=mp[st][i];
  vis[st]=1;
  for(int i=0;i<=n;i++)
  {
    int minn=inf,k=-1;
    for(int j=0;j<=n;j++)
    {
      if(!vis[j]&&dis[j]<minn)
      {
        minn=dis[j];
        k=j;
      }
    }
    if(k==-1)
      break;
    vis[k]=1;
    for(int j=0;j<=n;j++)
    {
      if(!vis[j]&&mp[k][j]!=inf)
      {
        if(dis[j]>mp[k][j]+dis[k])
        {
          dis[j]=mp[k][j]+dis[k];
          pre[j].clear();
          pre[j].push_back(k);//表示0~j的最短路上,j前面的点为k
        }
        else if(dis[j]==mp[k][j]+dis[k])//长度相同,及存在多条路
          pre[j].push_back(k);
      }
    }
  }
}
int minneed,minback;
void dfs(int x)
{
  g.push_back(x);
  if(x==0)//遇到起点,开始计算最短路径上的收补情况
  {
    int need=0,back=0;
    for(int i=g.size()-1;i>=0;i--)
    {
      int id=g[i];
      if(C[id]>0)//该站点需收回多余自行车
        back+=C[id];
      else//需补给自行车
      {
        if(back>-1*C[id])//已经收回的自行车够补给该站点
          back+=C[id];
        else//已经收回的不够
        {
          need+=(-1*C[id]-back);//需要从起始站点补给
          back=0;//收回的全部补给
        }
      }
    }
    if(need<minneed)//找最少补给
    {
      minneed=need;
      minback=back;
      path=g;
    }
    else if(need==minneed&&back<minback)
    {
      minback=back;
      path=g;
    }
    g.pop_back();//回溯
    return;
  }
  for(int i=0;i<pre[x].size();i++)
  {
    dfs(pre[x][i]);
  }
  g.pop_back();
}
int main()
{
  memset(mp,inf,sizeof(mp));
  //memset(dis,inf,sizeof(dis));
  scanf("%d%d%d%d",&c,&n,&sp,&m);
  for(int i=1;i<=n;i++)
  {
    scanf("%d",&C[i]);
    C[i]=C[i]-c/2;//将其转换为与完美状态的差别,多为+,少为-
  }
  for(int i=0;i<m;i++)
  {
    int x,y,z;
    scanf("%d%d%d",&x,&y,&z);
    mp[x][y]=z;
    mp[y][x]=z;
  }
  for(int i=1;i<=n;i++)
  {
    if(mp[i][0]!=inf) pre[i].push_back(0);
    //所有与起点有路径的站点,初始的前一个点为0
  }
  dijkstra(0,n);
  minneed=inf;
  minback=inf;
  dfs(sp);
  printf("%d 0",minneed);
  for(int i=path.size()-2;i>=0;i--)
    printf("->%d",path[i]);
  printf(" %d\n",minback);
  return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值