HDU 5583 Kingdom of Black and White 【贪心】


传送门:HDU 5583


Kingdom of Black and White

Problem Description
In the Kingdom of Black and White (KBW), there are two kinds of frogs: black frog and white frog.
Now N frogs are standing in a line, some of them are black, the others are white. The total strength of those frogs are calculated by dividing the line into minimum parts, each part should still be continuous, and can only contain one kind of frog. Then the strength is the sum of the squared length for each part.
However, an old, evil witch comes, and tells the frogs that she will change the color of at most one frog and thus the strength of those frogs might change.
The frogs wonder the maximum possible strength after the witch finishes her job.

Input
First line contains an integer T, which indicates the number of test cases.
Every test case only contains a string with length N, including only 0 (representing
a black frog) and 1 (representing a white frog).
⋅ 1≤T≤50.
⋅ for 60% data, 1≤N≤1000.
⋅ for 100% data, 1≤N≤105.
⋅ the string only contains 0 and 1.

Output
For every test case, you should output “Case #x: y”,where x indicates the case number and counts from 1 and y is the answer.

Sample Input
2
000011
0101

Sample Output
Case #1: 26
Case #2: 10



题目大意:
给你一个只有 0 和 1 的字符串,你可以改变一个字符,将其变反(0变1,1变0)。一个字符的值为被一段连续相同字符长度的和的平方和。要求你改变一个字符使值最大。


解题思路:
有一点我们一定要了解,我们改变的字符一定是连续段的头和尾的字符。因为平方的增加量是很大的(比如 42 变成 52 远大于 1+1+22),所以我们将每个连续的段看成固定组,改变相邻两组的值(+1,-1),枚举找最大值即可。



AC代码:

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cmath>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
const int N=1e5+10;
int t;
char s[N];
int a[N];
int main()
{
	scanf("%d",&t);
	int ca=0;
	while(t--)
	{
		memset(a,0,sizeof(a));
		scanf("%s",s);
		int len=strlen(s);
		s[len]='#';
		len++;
		ll tmp=1,cnt=1,sum=0;
		for(int i=1; i<len; i++)
		{
			if(s[i]==s[i-1])
				tmp++;
			else
			{
				a[cnt++]=tmp;
				sum+=tmp*tmp;
				tmp=1;
			}
		}
		ll maxn=sum;
		//  printf("%lld\n",sum);
		//在总值的基础上改变,不能每改一次重算一次,会超时
		for(int i=1; i<cnt-1; i++)
		{
			if(a[i+1]==1)
			{
				ll tmp=sum-a[i]*a[i]-a[i+1]*a[i+1]-a[i+2]*a[i+2]+(a[i]+a[i+1]+a[i+2])*(a[i]+a[i+1]+a[i+2]);
				maxn=max(maxn,tmp);
			}
			else
			{
				ll tmp=sum-a[i]*a[i]-a[i+1]*a[i+1]+(a[i]+1)*(a[i]+1)+(a[i+1]-1)*(a[i+1]-1);
				maxn=max(maxn,tmp);
			}
			if(a[i]==1)
			{
				ll tmp=sum-a[i]*a[i]-a[i+1]*a[i+1]-a[i-1]*a[i-1]+(a[i]+a[i+1]+a[i-1])*(a[i]+a[i+1]+a[i-1]);
				maxn=max(maxn,tmp);
			}
			else
			{
				ll tmp=sum-a[i]*a[i]-a[i+1]*a[i+1]+(a[i]-1)*(a[i]-1)+(a[i+1]+1)*(a[i+1]+1);
				maxn=max(maxn,tmp);
			}
		}
		printf("Case #%d: %lld\n",++ca,maxn);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值