HDU 1710 Binary Tree Traversals 【二叉树的遍历】


传送门:HDU 1710


Binary Tree Traversals
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description
A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.
In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.
In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.
In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.
Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.
在这里插入图片描述

Input
The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.

Output
For each test case print a single line specifying the corresponding postorder sequence.

Sample Input
9
1 2 4 7 3 5 8 9 6
4 7 2 1 8 5 9 3 6

Sample Output
7 4 2 8 9 5 6 3 1



题意:
给你一个二叉树的前序输出和中序输出,要你输出这个二叉树的后序输出。


题解:
由前序输出和中序输出的输出规则,我们递归的遍历他,来建树。建成树后题目就简单了。
(前序:开头根节点,然后左子树和右子树;中序:前面左子树,然后根节点,最后右子树)

由前序我们可以得到根节点,然后知道了根节点我们就可以由中序得到左子树的数目,递归左子树,右子树。(每次递归的每个子树都符合上述规则)



AC代码:

 #include<iostream>
 #include<algorithm>
 #include<cstdio>
 #include<cstring>
 #include<cmath>
 #include<vector>
 #define ll long long
 #define inf 0x3f3f3f3f
 using namespace std;
 int n;
 int front[1100],zhong[1100];
 vector<int> v;
 struct tree
 {
   int left,right;
 }t[11000];
 int build(int l1,int r1,int l2,int r2,int rt)//前序-中序
 {
   if(l2>r2)
   {
     return 0;
   }
   int root=front[l1];//由前序得根结点
   int p=l2;
   while(zhong[p]!=root)//在中序中得到左子树的数目
   {
     p++;
   }
   int cnt=p-l2-1;//左子树的个数
   t[root].left=build(l1+1,l1+1+cnt,l2,p-1,root<<1);//左子树递归,左子树递归
   t[root].right=build(l1+2+cnt,r1,p+1,r2,root<<1|1);//右子树递归,右子树递归
   return root;
 }
 void dfs(int x)//后序深搜
 {
   if(t[x].left==0&&t[x].right==0)//搜到根节点就返回,并存入数组
   {
     v.push_back(x);
     return;
   }
   if(t[x].left!=0)//先搜左子树
   {
     dfs(t[x].left);
   }
   if(t[x].right!=0)//搜右子树
   {
     dfs(t[x].right);
   }
   v.push_back(x);//搜完后将该节点存入数组
   return ;
 }
 int main()
 {
   while(scanf("%d",&n)!=EOF)
   {
     v.clear();
     memset(t,0,sizeof(t));
     for(int i=0;i<n;i++)//输入前序
     {
       scanf("%d",&front[i]);
     }
     for(int i=0;i<n;i++)//输入中序
     {
       scanf("%d",&zhong[i]);
     }
     int root=front[0];
     build(0,n-1,0,n-1,root);//建树
     dfs(root);//得到后序
     int len=v.size();
     for(int i=0;i<len;i++)
     {
       printf("%d%c",v[i],i==len-1?'\n':' ');
     }
   }
   return 0;
 }

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值