【PTA Advanced】1155 Heap Paths(C++)

目录

题目

Input Specification:

Output Specification:

Sample Input 1:

Sample Output 1:

Sample Input 2:

Sample Output 2:

Sample Input 3:

Sample Output 3:

思路

代码


题目

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

思路

难度评级:⭐️

1. path的输出

递归实现树的深度遍历,先访问右孩子,再访问左孩子即可。

2. 判断是否是堆

采用堆创建或者调整时的思路即可,从树的最后一个非叶子结点向上遍历,每次比对该节点和它孩子的大小是否符合大根堆/小根堆的规则

3. 大小根堆的判断如何只用一段代码实现

设置flag,大小根堆的flag值不同,在比对结点与其孩子大小时异或一下即可,具体代码见函数isHeap

代码

#include <iostream>
#include <vector>

using namespace std;

int n,heapFlag;
vector<int> nodes;

void printPath(int nodeIndex,vector<int> path) {
	path.push_back(nodes[nodeIndex]);
	
	// 叶子结点时
	if(nodeIndex*2>n) {
		// 输出path
		int flag=false;
		for(int node:path) {
			if(flag) cout<<" ";
			cout<<node;
			flag=true;
		}
		cout<<endl;
		return;
	}
	
	// 分支节点先遍历右孩子,再遍历左孩子
	if(nodeIndex*2+1<=n) printPath(nodeIndex*2+1,path);
	if(nodeIndex*2<=n) printPath(nodeIndex*2,path);
}

// 判断树是否是heapFlag类型的heap
bool isHeap() {
	// 从最后一个非叶子结点开始向前遍历
	for(int i=n/2;i>=1;i--) {
		if(i*2<=n&&(nodes[i]>=nodes[i*2])^heapFlag) return false;
		if(i*2+1<=n&&(nodes[i]>=nodes[i*2+1])^heapFlag) return false;
	} 
	return true;
}

int main(int argc, char** argv) {
	cin>>n;
	
	nodes.resize(n+1);
	for(int i=1;i<=n;i++) {
		int node;
		cin>>node;
		nodes[i]=node;
	}
	
	// 递归的方式输出path
	vector<int> path;
	printPath(1,path); 
	
	// 初步判断可能是什么heap
	if(nodes[1]>=nodes[n]) heapFlag=1;// 大根堆 
	else heapFlag=0;// 小根堆
	
	// 判断树是否是heapFlag类型的heap
	if(isHeap()){
		if(heapFlag==1) cout<<"Max Heap";
		else cout<<"Min Heap";
	}else cout<<"Not Heap";
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值