【PTA Advanced】1150 Travelling Salesman Problem(C++)

本文介绍了旅行商问题的背景和一个具体的实例,通过C++解决一个寻找最接近旅行商问题解决方案的题目。输入包含城市数量、边的数量和各个路径,输出包括每个路径的总距离及其类型,并找出最接近的旅行商路径。
摘要由CSDN通过智能技术生成

目录

题目

Input Specification:

Output Specification:

Sample Input:

Sample Output:

思路

代码


题目

The "travelling salesman problem" asks the following question: "Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?" It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from "https://en.wikipedia.org/wiki/Travelling_salesman_problem".)

In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist, where the cities are numbered from 1 to N and the distance Dist is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:

n C1​ C2​ ... Cn​

where n is the number of cities in the list, and Ci​'s are the cities on a path.

Output Specification:

For each path, print in a line Path X: TotalDist (Description) where X is the index (starting from 1) of that path, TotalDist its total distance (if this distance does not exist, output NA instead), and Description is one of the following:

  • TS simple cycle if it is a simple cycle that visits every city;
  • TS cycle if it is a cycle that visits every city, but not a simple cycle;
  • Not a TS cycle if it is NOT a cycle that visits every city.

Finally print in a line Shortest Dist(X) = TotalDist where X is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist is its total distance. It is guaranteed that such a solution is unique.

Sample Input:

6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6

Sample Output:

Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8

思路

难度评级:⭐️⭐️

步骤:(就是简单的分支判断)

1. 沿着path走一遍,遇到不可达的路径,说明该path一定不是TS cycle且dist无法计算

2. 所有路径都可达时即dist可计算出来时,检查path首尾是否是同一个city以及path是否经过了所有的city,如果不是,则该path一定不是一个TS cycle

3. 上面条件都满足时,只需要检查path上的城市数量是否刚好等于所有城市数量(n)+1,如果满足,说明这是一个TS simple cycle,否则是TS cycle

4. 比较得出满足上面步骤3的path中的dist最小的那个就是shortest dist

代码

#include <iostream>
#include <vector>
#include <set>

using namespace std;

int matrix[201][201]={0};

int main(int argc, char** argv) {
	int n,m;
	cin>>n>>m;
	
	for(int i=0;i<m;i++) {
		int row,col;
		cin>>row>>col;
		cin>>matrix[row][col];
		matrix[col][row]=matrix[row][col];
	}
	
	int pathNum,shortestPath=-1,shortestDist=0x7fffffff; 
	cin>>pathNum;
	for(int i=1;i<=pathNum;i++) {
		int cityNum,dist=0;
		cin>>cityNum;
		
		vector<int> path(cityNum);
		set<int> hasCity;
		for(int j=0;j<cityNum;j++) {
			cin>>path[j];
			hasCity.insert(path[j]);
		}
		 
		// 初步判断该条路径是否可能是一个TS cycle 
		bool isCycle=(path[0]==path[cityNum-1]&&hasCity.size()==n);
		// 统计dist
		int j;
		for(j=0;j<cityNum-1;j++) {
			// 路径不可达,则一定不是一个TS cycle,且没有dist值 
			if(matrix[path[j]][path[j+1]]==0) {
				cout<<"Path "<<i<<": NA (Not a TS cycle)"<<endl;
				isCycle=false;
				break;
			}else {
				dist+=matrix[path[j]][path[j+1]];
			}
		}
		// 可以计算出dist的情况 
		if(j>=cityNum-1) {
			if(!isCycle) printf("Path %d: %d (Not a TS cycle)\n",i,dist);
			else {
				if(cityNum==n+1) printf("Path %d: %d (TS simple cycle)\n",i,dist);
				else printf("Path %d: %d (TS cycle)\n",i,dist);
				// 判断该条路径是否更短 
				if(dist<=shortestDist) {
					shortestDist=dist;
					shortestPath=i;
				}
			}
		}
	}
	
	printf("Shortest Dist(%d) = %d",shortestPath,shortestDist);
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值