#POJ 3114 Countries in War (Tarjan + dijkstra )

Total Submissions: 5262 Accepted: 1529

Description

In the year 2050, after different attempts of the UN to maintain peace in the world, the third world war broke out. The importance of industrial, commercial and military secrets obliges all the countries to use extremely sophisticated espionage services, so that each city in the world has at least one spy of each country. These spies need to communicate with other spies, informers as well as their headquarters during their actions. Unluckily there doesn’t exist a secure way for a spy to communicate during the war period, therefore the messages are always sent in code so that only the addressee is able to read the message and understand its meaning.

The spies use the only service that functions during the war period, the post. Each city has a postal agency where the letters are sent. The letters can be sent directly to their destination or to other postal agencies, until the letter arrives at the postal agency of the destination city, if possible.

The postal agency in city A can send a printed letter to the postal agency in city B if there is an agreement on sending letters, which determines the time, in hours, that a letter takes to reach city B from city A (and not necessarily the opposite). If there is no agreement between the agencies A and B, the agency A can try to send the letter to any agency so that the letter can reach its destination as early as possible

Some agencies are connected with electronic communication media, such as satellites and optical fibers. Before the war, these connections could reach all the agencies, making that a letter could be sent instantly. But during the period of hostilities every country starts to control electronic communication and an agency can only send a letter to another agency by electronic media (or instantly) if they are in the same country. Two agencies, A and B, are in the same country if a printed letter sent from any one of the agencies can be delivered to the other one.

The espionage service of your country has managed to obtain the content of all the agreements on sending messages existing in the world and desires to find out the minimum time to send a letter between different pairs of cities. Are you capable of helping them?

Input

The input contains several test cases. The first line of each test case contains two integer separated by a space, N (1 ≤ N ≤ 500) and E (0 ≤ EN2), indicating the numbers of cities (numbered from 1 to N) and of agreements on sending messages, respectively. Following them, then, E lines, each containing three integers separated by spaces, X, Y and H (1 ≤ X, YN, 1 ≤ H ≤ 1000), indicating that there exist an agreement to send a printed letter from city X to city Y, and that such a letter will be delivered in H hours.

After that, there will be a line with an integer K (0 ≤ K ≤ 100), the number of queries. Finally, there will be K lines, each representing a query and containing two integers separated by a space, O and D (1 ≤ O, DN). You must determine the minimum time to send a letter from city O to city D.

The end of the input is indicated by N = 0.

Output

For each test case your program should produce K lines of output. The I-th line should contain an integer M, the minimum time, in hours, to send a letter in the I-th query. If there aren’t communication media between the cities of the query, you should print “Nao e possivel entregar a carta” (“It’s impossible to deliver the letter”).

Print a blank line after each test case.

Sample Input

4 5
1 2 5
2 1 10
3 4 8
4 3 7
2 3 6
5
1 2
1 3
1 4
4 3
4 1
3 3
1 2 10
2 3 1
3 2 1
3
1 3
3 1
3 2
0 0

Sample Output

0
6
6
0
Nao e possivel entregar a carta

10
Nao e possivel entregar a carta
0

 

 题目大意 : 输入一个有向图, 每个国家之间传输信息只能通过各自的通信媒介,每次询问输出两点之间的最短路。

思路 : 强连通题,首先将图缩点,这样就能把所有的通信媒介表示出来了,然后将缩点后的点之间的边存下来,再用最短路就OK,不明白的话看下面的图

以第一个样例为例 : 

 

 如图所示, 缩点后,1的集合中包含了原图中的1、2; 2的集合中包含了原图中的3、4,只添加不在一个集合中的边就好,注意输入要用scanf,并且每个样例后要输出一行回车!!

AC代码 : 

#include<stdio.h>
#include<iostream>
#include<cstring>
#include<queue>
#include<stack>
using namespace std;
const int maxn = 1e5 + 5;
const int INF = 0x3f3f3f3f;

struct node
{
    int v, w, next;
}e[maxn], d[maxn];
struct edge
{
    int id, w;
    bool operator < (const edge  &oth) const
    {
        return w > oth.w;
    }
}mid;
int dfn[maxn], low[maxn], suo[maxn], cnt, scnt, ant, tot;
int head[maxn], hed[maxn], dis[maxn], n, m, K;
bool vis[maxn];
stack <int> st;
priority_queue <edge> q;
void init() {
    memset(e, 0, sizeof(e));
    memset(d, 0, sizeof(d));
    memset(head, -1, sizeof(head));
    memset(hed, -1, sizeof(hed));
    memset(suo, 0, sizeof(suo));
    memset(dfn, 0, sizeof(dfn));
    memset(low, 0, sizeof(low));
    memset(vis, 0, sizeof(vis));
    cnt = tot = scnt = ant = 0;
}
void add (int from, int to, int dis) { //存原图
    e[++cnt].v = to;
    e[cnt].w = dis;
    e[cnt].next = head[from];
    head[from] = cnt;
}
void ad (int from, int to, int dis) { // 存新图
    d[++ant].v = to;
    d[ant].w = dis;
    d[ant].next = hed[from];
    hed[from] = ant;
}
void tarjan(int x) {
    dfn[x] = low[x] = ++tot;
    vis[x] = 1;
    st.push(x);
    for (int i = head[x]; i != -1; i = e[i].next) {
        if (!dfn[e[i].v]) {
            tarjan(e[i].v);
            low[x] = min (low[x], low[e[i].v]);
        }
        else if (vis[e[i].v]) low[x] = min (low[x], dfn[e[i].v]);
    }
    if (dfn[x] == low[x]) {
        scnt++;
        int k;
        do {
            k = st.top();
            st.pop();
            suo[k] = scnt; // suo值相等表示在一个集合
            vis[k] = 0;
        }
        while (k != x);
    }
}
void dijkstra(int u) {
    memset(dis, INF, sizeof(dis));
    dis[u] = 0;
    q.push({u, 0});
    while (!q.empty()) {
        mid = q.top();
        q.pop();
        int ans = mid.id;
        if (mid.w != dis[ans]) continue;
        for (int i = hed[ans]; i != -1; i = d[i].next) {
            if (dis[d[i].v] > dis[ans] + d[i].w) {
                dis[d[i].v] = dis[ans] + d[i].w;
                q.push({d[i].v, dis[d[i].v]});
            }
        }
    }
}

int main()
{
    while (scanf("%d", &n) && n) {
        scanf("%d", &m);
        init();
        for (int i = 0; i < m; i++) {
            int ui, vi, wi;
            scanf("%d%d%d", &ui, &vi, &wi);
            add (ui, vi, wi);
        }
        for (int i = 1; i <= n; i++) {
            if (!dfn[i]) tarjan(i);
        }
        for (int i = 1; i <= n; i++) {
            for (int j = head[i]; j != -1; j = e[j].next) {
                if (suo[i] != suo[e[j].v]) ad (suo[i], suo[e[j].v], e[j].w);
            } //新图存边
        }
        scanf("%d", &K);
        while (K--) {
            int ui, vi;
            scanf("%d%d", &ui, &vi);
            dijkstra(suo[ui]);
            if (dis[suo[vi]] != INF) cout << dis[suo[vi]] << endl;
            else cout << "Nao e possivel entregar a carta" << endl;
        }
        cout << endl;
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值