简单搜索 - 迷宫问题

题目描述

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

Code

#include <iostream>
#include <stdio.h>
#include <queue>
#include <string.h>

using namespace std;


const int MAXN=5;
int map[MAXN][MAXN],vis[MAXN][MAXN];


struct node{
    int a,b;
    string s;
    node(int i=0,int j=0,string ss=""){
        a=i;
        b=j;
        s=ss;
    }
};

int dir1[4]={-1,1,0,0};
int dir2[4]={0,0,-1,1};


void print_ans(string s){
    int a=0,b=0;
    cout<<"("<<a<<", "<<b<<")"<<endl;
    for(int i=0;i<s.length();i++){
        if(s[i]=='0') a -= 1;
        if(s[i]=='1') a += 1;
        if(s[i]=='2') b -= 1;
        if(s[i]=='3') b += 1;
        cout<<"("<<a<<", "<<b<<")"<<endl;
    }
}

string bfs(){
    queue<node> q;
    q.push(node());
    vis[0][0]=1;
    while(!q.empty()){
        node tmp=q.front();
        q.pop();
        if(tmp.a==4&&tmp.b==4) return tmp.s;

        for(int i=0;i<4;i++){
            string ss = "0";
            ss[0] = ss[0]+i;
            node nxt = node(tmp.a+dir1[i],tmp.b+dir2[i],tmp.s+ss);
            if(nxt.a>=0&&nxt.a<5&&nxt.b>=0&&nxt.b<5&&!vis[nxt.a][nxt.b]&&map[nxt.a][nxt.b]==0){
                vis[nxt.a][nxt.b]==1;
                q.push(nxt);
            }
        }
    }
    return "";
}

int main(){
    //freopen("/Users/guoyu/Desktop/algorithm/in.txt", "r", stdin);
    for(int i=0;i<5;i++) {
        for (int j = 0; j < 5; j++)
            cin >> map[i][j], vis[i][j] = 0;
    }

    string ans =bfs();
    print_ans(ans);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值