Description
啤酒每罐2.3元,饮料每罐1.9元。小明买了若干啤酒和饮料,一共花了N元。请你计算他买了几罐啤酒和几罐饮料(罐数为整数)。
Input
一个double型数据N(0<=N<=20000)
Output
输出啤酒和饮料的罐数,如果存在多组结果按照啤酒数从大到小排列;如果没有解答输出"No Solution"
Sample Input
82.3
Sample Output
30 7
11 30
暴力水题 精度着实重要 卡了好多次
#include <bits/stdc++.h>
using namespace std;
int main()
{
int a,b;
double n;
while(cin>>n)
{
int tmp=(int)n/2.3;
int f=0;
for(int i=tmp; i>=0; i--)
{
double tmp1=(n-2.3*i)/1.9;
int tmp2=(int)tmp1;
// cout<<tmp1<<' '<<tmp2<<'\n';
if(tmp1-tmp2<1e-7)
{
f=1;
cout<<i<<' '<<tmp2<<'\n';
}
}
if(!f)
cout<<"No Solution"<<'\n';
}
return 0;
}