Trailing Zeroes (III) LightOJ - 1138(二分)

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 12…*N. For example, 5! = 120, 120 contains one zero on the trail.

Input
Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output
For each case, print the case number and N. If no solution is found then print ‘impossible’.

Sample Input
3

1

2

5

Sample Output
Case 1: 5

Case 2: 10

Case 3: impossible

题意:

给你n个0,让你判断那个数的阶乘值算出来后面有n个0(或者存在这个数不存在);

思路;
举个栗子:11的阶乘 11/5=2; 2/5=0; 2 + 0= 2; 则11含有两个0; 原理就是这样;暴力不断相处即可,求出来含有5的个数

#include<stdio.h>
const int MAXN=0x3f3f3f3f;//这个要足够大才能找到10^8 
int getq(int x){
    int q=0;
    while(x){
        q+=x/5;
        x/=5;
    }
    return q;
}
void erfen(int n){
    int l=0,r=MAXN;
    while(l<=r){
        int mid=(l+r)>>1;
        if(getq(mid)>=n)r=mid-1;//二分这点注意 
        else l=mid+1;
    }
    if(getq(l)==n)printf("%d\n",l);
    else puts("impossible");
}
int main(){
    int T,Q,flot=0;
    scanf("%d",&T);
    while(T--){
        scanf("%d",&Q);
        printf("Case %d: ",++flot);
         erfen(Q);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值