POJ 2184--Cow Exhibition 01背包

Description

“Fat and docile, big and dumb, they look so stupid, they aren’t much
fun…”

  • Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si’s and, likewise, the total funness TF of the group is the sum of the Fi’s. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.
Input

  • Line 1: A single integer N, the number of cows

  • Lines 2…N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.
    Output

  • Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5
Sample Output

8
Hint

OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value
of TS+TF to 10, but the new value of TF would be negative, so it is not
allowed.

最近DP题库集训快完了,最后几个都是之前不会的,感觉很有价值,写下来做笔记。
题目大意:两个数字,代表牛的两个属性,选的两个数字的和,但两个分别的和都不能是负数。
可以把S当体积,F当价值做01背包。dp【i】表示当前S【i】对应最大F
但是注意是S可为负,所以整体加100000,即0-100000为负数,100000-200000是正数。
所以dp的时候正序逆序要注意
还有就是注意DP时的范围,凡是可能影响的都要包括。

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
int t;
const int INF = 0x3f3f3f3f;
int s, f, dp[200010];
using namespace std;
int main() {
    while(cin >> t) {
        for(int i=0;i<=200000;i++)dp[i]=-INF;
        dp[100000] = 0;
        for(int i = 0; i < t; i++) {
            cin >> s >> f;
            if(s < 0 && f < 0)
                continue;
            if(s > 0) {
                for(int j = 200000; j >= s; j--) {
                   // if(dp[j - s] > -INF)
                        dp[j] = max(dp[j], dp[j - s] + f);
                }
            } else {
                for(int j = 0; j <= 200000 + s; j++) {
                   // if(dp[j - s] > -INF)
                        dp[j] = max(dp[j], dp[j - s] + f);
                }
            }
        }
        int ans = 0;
        for(int i = 100000; i <= 200000; i++)
            if(dp[i] >= 0 && dp[i] + i - 100000 > ans)
                ans = dp[i] + i - 100000;
        printf("%d\n", ans);
    }
    return 0;
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值