PAT A1027 Colors in Mars

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:
Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:
For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

接下来是AC代码:

#include <iostream>
#include <cstdio> 
int main(void) {
	char shuzi[13]={'0','1','2','3','4','5','6','7','8','9','A','B','C'};
	int a,b,c;
	scanf("%d%d%d",&a,&b,&c);
	printf("#");
	printf("%c%c",shuzi[a/13],shuzi[a%13]);
	printf("%c%c",shuzi[b/13],shuzi[b%13]);
	printf("%c%c",shuzi[c/13],shuzi[c%13]);
	return 0;
}

解题思路:
1.题目的范围小于169,所以这个数的13进制形式只会有2位数,这样一来就简单多了,把每个数字的两个数都算出来就好了
2.也可以用除基取余法,这样比较通用,但是较为麻烦
需要注意:
1.注意结果与数字的对应

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

纳萨斯瓦德

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值