PAT A1027 Colors in Mars (20分)

PAT A1027 Colors in Mars 20分

原题

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.
Input Specification:
Each input file contains one test case which occupies a line containing the three decimal color values.
Output Specification:
For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.
Sample Input:
15 43 71
Sample Output:
#123456

大体题意

就是非常直接的进制转换,十三进制

思路

个位数要记得补0

代码

#include <iostream>
using namespace std;

//将十进制转换为十三进制
//范围只有0-168
//因此输出的是两位,如果只有一位,要在前面补0
int change(int num)
{
	int m = 0;
	int c, f[2], i;
	while (num)
	{
		c = num % 13;
		//cout << "c = " << c << endl;
		num = num / 13;
		f[m] = c;
		m++;
	}
	if (m == 0)
	{
		cout << "00";
	}
	else if (m == 1)
	{
		cout << 0;
		if (f[0] >= 10)
		{
			cout << (char)(f[0] + 55);
		}
		else
		{
			cout << f[0];
		}
	}
	else 
	{
		for (i = m - 1; i >= 0; i--)
		{
			//cout << f[i] << " ";
			if (f[i] >= 10)
			{
				cout << (char)(f[i] + 55);
			}
			else
			{
				cout << f[i];
			}
		}
	}
	return 0;
}
int main()
{
	int r, g, b;
	cin >> r >> g >> b;
	cout << "#";
	change(r);
	change(g);
	change(b);
}

运行结果

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值