F - 2^x mod n = 1 HDU - 1395

2^x mod n = 1

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21451 Accepted Submission(s): 6725

Problem Description
Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1.

Input
One positive integer on each line, the value of n.

Output
If the minimum x exists, print a line with 2^x mod n = 1.

Print 2^? mod n = 1 otherwise.

You should replace x and n with specific numbers.

Sample Input
2
5

Sample Output
2^? mod 2 = 1
2^4 mod 5 = 1

思路:

  1. 取模运算,每次取模数据不会溢出。
  2. 这道题开始写的时候发现时间超时,然后用快速幂,提交后还超时。
  3. 找规律发现遍历n一个循环,然后优化一直超时,提交了数次。浪费了很多时间,大意了。

AC:

#include<iostream>
using namespace std;
int main(){
	int n;
	while(cin>>n){
		if(n%2==0||n==1){
			cout<<"2^? mod "<<n<<" = 1"<<endl;
		}else{
			int ans = 1,k=0;
			while(1){
				k++;
				ans = (ans*2)%n;
				if(ans==1){
					break;
				}
			}
			cout<<"2^"<<k<<" mod "<<n<<" = 1"<<endl;
		}
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值