【Java】并查集

题目描述

在某个城市中住着n个人,现在给定关于这n个人的m条信息(即某2个人认识)。

假设所有认识的人一定属于同一个单位,请计算该城市有多少个单位?

输入

第1行的第1个值表示总人数n,第2个值表示总信息数m;第2行开始为具体的认识关系信息

输出

单位的个数

样例输入 Copy

10 4
2 3
4 5
4 8
5 8

样例输出 Copy

7

package book;

import java.util.Scanner;

/*
 * 并查集
 */
public class Uoion {

	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		int n=sc.nextInt();//n个人
		int m=sc.nextInt();//m条信息
		int father[]=new int[n];
		int count=0;
		int pre[]=new int[n];
		for(int i=0;i<n;i++) {
			father[i]=Integer.MAX_VALUE;
			pre[i]=i;
		}
		for(int i=0;i<m;i++) {
			int dad=sc.nextInt();
			int child=sc.nextInt();
			pre[child]=dad;
		}
		for(int i=0;i<n;i++) {
			boolean fa=true;
			int re=slove(i,pre);
			for(int j=0;j<n;j++) {
				if(re==father[j]) {
					fa=false;
				}
			}
			if(fa) {
				father[i]=re;
			}
		}
		 for(int i=0;i<n;i++) {
	        	if(father[i]!=Integer.MAX_VALUE) {
	        		count++;
	        	}
	        }
	        System.out.println(count);
	  }

	private static int slove(int i, int[] pre) {
	   if(i==pre[i]) {
		   return pre[i];
	   }
	   else{
		   return slove(pre[i],pre);
	   }
		
	}

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Coder .

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值