Menagerie

题目描述
Snuke, who loves animals, built a zoo.
There are N animals in this zoo. They are conveniently numbered 1 through N, and arranged in a circle. The animal numbered i(2≤i≤N−1) is adjacent to the animals numbered i−1 and i+1. Also, the animal numbered 1 is adjacent to the animals numbered 2 and N, and the animal numbered N is adjacent to the animals numbered N−1 and 1.
There are two kinds of animals in this zoo: honest sheep that only speak the truth, and lying wolves that only tell lies.
Snuke cannot tell the difference between these two species, and asked each animal the following question: “Are your neighbors of the same species?” The animal numbered i answered si. Here, if si is o, the animal said that the two neighboring animals are of the same species, and if si is x, the animal said that the two neighboring animals are of different species.
More formally, a sheep answered o if the two neighboring animals are both sheep or both wolves, and answered x otherwise. Similarly, a wolf answered x if the two neighboring animals are both sheep or both wolves, and answered o otherwise.
Snuke is wondering whether there is a valid assignment of species to the animals that is consistent with these responses. If there is such an assignment, show one such assignment. Otherwise, print -1.

Constraints
3≤N≤105
s is a string of length N consisting of o and x.

输入
The input is given from Standard Input in the following format:
N
s

输出
If there does not exist an valid assignment that is consistent with s, print -1. Otherwise, print an string t in the following format. The output is considered correct if the assignment described by t is consistent with s.
·t is a string of length N consisting of S and W.
·If ti is S, it indicates that the animal numbered i is a sheep. If ti is W, it indicates that the animal numbered i is a wolf.

样例输入
6
ooxoox

样例输出
SSSWWS

提示
For example, if the animals numbered 1, 2, 3, 4, 5 and 6 are respectively a sheep, sheep, sheep, wolf, wolf, and sheep, it is consistent with their responses. Besides, there is another valid assignment of species: a wolf, sheep, wolf, sheep, wolf and wolf.
Let us remind you: if the neiboring animals are of the same species, a sheep answers o and a wolf answers x. If the neiboring animals are of different species, a sheep answers x and a wolf answers o.

在这里插入图片描述
思路
假设所有情况下的第一二个动物的种类,通过序列推出结果再对假设进行比较,如能对应则输出,若没有假设符合,则输出-1

代码实现

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <queue>
#include <stack>
#include <map>
#include <cmath>
using namespace std;
typedef long long ll;
typedef pair<int,int> P;
const int N=200010;
const int mod=998244353;
char str[N];
int n,w=5;
bool l[N];
void output()
{
    for(int i=0;i<n;i++)
    {
        if(l[i]) printf("S");
        else printf("W");
    }
    printf("\n");
}
int main()
{
    scanf("%d%s",&n,str);
    str[n]=str[0];
    str[n+1]=str[1];
    str[n+2]='\0';
    while(w--)
    {
        if(w==4) l[0]=1,l[1]=1;
        else if(w==3)   l[0]=1,l[1]=0;
        else if(w==2)   l[0]=0,l[1]=0;
        else if(w==1)   l[0]=0,l[1]=1;
        for(int i=1;i<=n;i++)
        {
            if(l[i])
            {
                if(str[i]=='o') l[i+1]=l[i-1];
                else if(str[i]=='x')    l[i+1]=!l[i-1];
            }
            else
            {
                if(str[i]=='o') l[i+1]=!l[i-1];
                else if(str[i]=='x')    l[i+1]=l[i-1];
            }
        }
        if(l[n]==l[0] && l[n+1]==l[1])
        {
            output();
            return 0;
        }
    }
    printf("-1\n");
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值