Hakase and Nano

题目描述

Hakase and Nano are playing an ancient pebble game (pebble is a kind of rock). There are n packs of pebbles, and the i-th pack contains ai pebbles. They take turns to pick up pebbles. In each turn, they can choose a pack arbitrarily and pick up at least one pebble in this pack. The person who takes the last pebble wins.
This time, Hakase cheats. In each turn, she must pick pebbles following the rules twice continuously.
Suppose both players play optimally, can you tell whether Hakase will win?

输入

The first line contains an integer T (1≤T≤20) representing the number of test cases.
For each test case, the fi rst line of description contains two integers n(1≤n≤106) and d (d = 1 or d = 2). If d = 1, Hakase takes first and if d = 2, Nano takes first. n represents the number of pebble packs.
The second line contains n integers, the i-th integer ai (1≤ai≤109) represents the number of pebbles in the i-th pebble pack.

输出

For each test case, print “Yes” or “No” in one line. If Hakase can win, print “Yes”, otherwise, print “No”.

样例输入
2
3 1
1 1 2
3 2
1 1 2

样例输出

Yes
No

思路
当Hakase为先手时,只有在ai都等于1且n为3的倍数时, Hakase方失利,当Hakase为后手时,只有在ai都等于1且n与3的模为1或存在一个ai大于1且n与3的模小于等于1时, Hakase方失利

代码实现

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>

using namespace std;
typedef long long ll;
const int N=1000005;
const int mod=998244353;
int T,n,d;

int main()
{
    scanf("%d",&T);
    while(T--)
    {
        int s=0;
        scanf("%d%d",&n,&d);
        for(int i=0;i<n;i++)
        {
            int temp;
            scanf("%d",&temp);
            if(temp>1) s++;
        }
        if(d==1)
        {
            if(s==0)
            {
                if(n%3==0)  printf("No\n");
                else printf("Yes\n");
            }
            else printf("Yes\n");
        }
        else
        {
            if(s==0)
            {
                if(n%3==1)  printf("No\n");
                else printf("Yes\n");
            }
            else
            {
                if(s>1) printf("Yes\n");
                else
                {
                    if(n%3<=1) printf("No\n");
                    else printf("Yes\n");
                }
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值