Balanced Neighbors(图)

本文介绍了一种算法,用于构建满足特定条件的无向图:图必须是简单的、连通的,并且每个顶点的相邻顶点索引之和相等。文章详细解释了如何根据顶点数量是奇数还是偶数来调整边的数量,从而确保图满足上述条件。通过实例展示了当顶点数为3时,如何构造这样的图。
摘要由CSDN通过智能技术生成

题目描述
You are given an integer N. Build an undirected graph with N vertices with indices 1 to N that satisfies the following two conditions:
·The graph is simple and connected.
·There exists an integer S such that, for every vertex, the sum of the indices of the vertices adjacent to that vertex is S.
It can be proved that at least one such graph exists under the constraints of this problem.

Constraints
·All values in input are integers.
·3≤N≤100

输入
Input is given from Standard Input in the following format:

N

输出
In the first line, print the number of edges, M, in the graph you made. In the i-th of the following M lines, print two integers ai and bi, representing the endpoints of the i-th edge.
The output will be judged correct if the graph satisfies the conditions.

样例输入
3

样例输出
2
1 3
2 3

提示
For every vertex, the sum of the indices of the vertices adjacent to that vertex is 3.

思路
先建立一个1到n的完全图,消边即可得到规律,当n为偶数时,总边数为n*(n-2)/2,当i+j == n+1时消边,当n为奇数时,总边数为(n-1)*(n-1)/2,当i+j ==n时消边。

代码实现

#include<bits/stdc++.h>
using namespace std;

const int N=105;
const int mod=1000000007;
typedef long long ll;

int n;

int main()
{
    scanf("%d",&n);
    if(n&1)
    {
        printf("%d\n",(n-1)*(n-1)/2);
        for(int i=1;i<n;i++)
        {
            for(int j=i+1;j<=n;j++)
            {
                if((i+j)!=n) printf("%d %d\n",i,j);
            }
        }
    }
    else
    {
        printf("%d\n",n*(n-2)/2);
        for(int i=1;i<n;i++)
        {
            for(int j=i+1;j<=n;j++)
            {
                if((i+j)!=(n+1)) printf("%d %d\n",i,j);
            }
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值