1150 Travelling Salesman Problem (25 分)

1150 Travelling Salesman Problem (25 分)

The “travelling salesman problem” asks the following question: “Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?” It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from “https://en.wikipedia.org/wiki/Travelling_salesman_problem”.)

In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist, where the cities are numbered from 1 to N and the distance Dist is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:

n C1 C2 ……Cn​​

where n is the number of cities in the list, and C​i‘s are the cities on a path.

Output Specification:

For each path, print in a line Path X: TotalDist (Description) where X is the index (starting from 1) of that path, TotalDist its total distance (if this distance does not exist, output NA instead), and Description is one of the following:

TS simple cycle if it is a simple cycle that visits every city;
TS cycle if it is a cycle that visits every city, but not a simple cycle;
Not a TS cycle if it is NOT a cycle that visits every city.
Finally print in a line Shortest Dist(X) = TotalDist where X is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist is its total distance. It is guaranteed that such a solution is unique.

Sample Input:

6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6

Sample Output:

Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8
题目大意:TScycle是拜访所有城市后回到原来的城市,给定所有边长以及路线,问路线的长度以及cycle的种类(分为TS simple cycle——每个城市走一遍,回到原城市,TS cycle——有城市走了不止一遍,Not a TS cycle——不是TS cycle)
分析: 路径上存在某两点不可达或者第一个结点与最后一个结点不同或者路径没有走完所有的点,则不是TS cycle,否则是的话,根据结点个数是否等于n+1判断是TS simple cycle或者TS cycle,对于TScycle记录最短路径编号和长度最后一行输出。
PS:这里我采用的是hash记录判断是否走过所有点,同样可以采用set、map等,set相对更方便。

#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn = 210;
const int INF = (1 << 30) - 1;
int G[maxn][maxn];
int n, m, k, shortestDis = INF, si = -1;
int main() {
	scanf("%d %d", &n, &m);
	fill(G[0], G[0] + maxn * maxn, INF);
	for (int i = 0; i < m; ++i) {
		int u, v, l;
		scanf("%d %d %d", &u, &v, &l);
		G[u][v] = G[v][u] = l;
	}
	scanf("%d", &k);
	for (int i = 1; i <= k; ++i) {
		int t, TotalDis = 0;
		bool flag = false, hashTable[maxn] = { false }, allGo = true; //判断INF
		scanf("%d", &t);
		vector<int> path(t);
		for (int j = 0; j < t; ++j) scanf("%d", &path[j]);
		for (int j = 0; j < t - 1; ++j) {
			int u = path[j], v = path[j + 1];
			hashTable[u] = hashTable[v] = true;
			if (G[u][v] == INF) {
				flag = true;
				break;
			}
			TotalDis += G[u][v];
		}
		if (flag == true) {//不可达
			printf("Path %d: NA (Not a TS cycle)\n", i);
			continue;
		}
		for (int i = 1; i <= n; ++i) {
			if (hashTable[i] == false) {
				allGo = false;
				break;
			}
		}
		if (allGo == false) {//有点没访问
			printf("Path %d: %d (Not a TS cycle)\n", i, TotalDis);
			continue;
		}
		else {//所有点均访问
			if (path[0] == path[t - 1]) {
				if (t == n + 1) printf("Path %d: %d (TS simple cycle)\n", i, TotalDis);
				else printf("Path %d: %d (TS cycle)\n", i, TotalDis);
				if (TotalDis < shortestDis) {
					shortestDis = TotalDis;
					si = i;
				}
			}
			else printf("Path %d: %d (Not a TS cycle)\n", i, TotalDis);//第一个结点与最后一个结点不相同
		}

	}
	printf("Shortest Dist(%d) = %d\n", si, shortestDis);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值