Arbitrage(HDU 1217)---货币汇率问题floyd算法

题目链接

题目描述

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.
Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

输入格式

The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

输出格式

For each test case, print one line telling whether arbitrage is possible or not in the format “Case case: Yes” respectively “Case case: No”.

输入样例

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar
3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar
0

输出样例

Case 1: Yes
Case 2: No

分析

floyd算法变形,最短路问题变成货币汇率问题,求是否存在一条兑换路径使得兑换一圈后手上的货币增加,具体看代码

源程序

Floyd算法

#include <bits/stdc++.h>
#define MAXN 35
using namespace std;
string a,b;
int n,m,cnt;
double dollor,g[MAXN][MAXN];
void init()
{
	memset(g,0,sizeof(g));	
	for(int i=1;i<=n;i++)g[i][i]=1;
} 
void floyd()
{
	for(int k=1;k<=n;k++)
		for(int i=1;i<=n;i++)
			for(int j=1;j<=n;j++)
				if(g[i][j]<g[i][k]*g[k][j])
					g[i][j]=g[i][k]*g[k][j];
}
int main()
{
	int cas=0;
	while(cin>>n&&n){
		map<string,int> M;
		init();	//初始化 
		for(int i=1;i<=n;i++){	//读入货币 
			cin>>a;
			M[a]=i;
		}
		scanf("%d",&m);
		for(int i=1;i<=m;i++){
			cin>>a>>dollor>>b;
			g[M[a]][M[b]]=dollor;
		} 
		floyd();
		bool flag=false;	//标记是否存在路线 
		for(int i=1;i<=n;i++){
			if(g[i][i]>1.0){
				flag=true;
				break;
			} 
		}
		if(flag)printf("Case %d: Yes\n",++cas);
		else printf("Case %d: No\n",++cas);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值